Should I be seeing Z-Wave JS to MQTT in my Intregrations

Its not there… It shows up and “Normal” in the supervisor’s "Installed Add On " page but not in the integration page… Like it was when I first installed it.

I’m seeing “some flakiness” in my Z-Wave devices automations sometimes not firing etc. but no systemic failure…


Depending on how you have zwavejs2mqtt set up you should nave wether mqtt integration or zwavejs integration.

Using websockets & the zwavejs integration is preferred, I believe.


and from the Z-Wave JS applet

The Host here is disabled.

HA is looking for Websockets but not connecting.

So I’m guessing I have the Z Wave integration installed and not ZWaveJS2MQTT… therfore I should NOT see ZWaveJS2MQTT as an integration.

Ok… I’m beginning to believe that I don’t really need ZWaveJS2MQTT to have Z-Wave working on my instance of HA.

I installed both because I was following a setup guide (The Guide) which described installing both… I thought that they were dependent on each other.

Both are displayed in my Supervisor Add-on page but only ZWaveJS is displayed as an integration

If you are running Home Assistant Image or Home Assistant Supervised, you can install either zwaejs or zwavejs2mqtt from the Addons Store.

The zwavejs Addon requires the zwavejs integration.

The zwavejs2mqtt addon can either be set up to use the mqtt integration OR the zwavejs integration, Many people, including me, choose the latter.

Ok… thanks…
How do I get / set the web sockets connection?
Using this?.. “ws://a0d7b954-zwavejs2mqtt:3000” in the network field of Z-Wave JS To MQTT shown above?


I believe that line goes in the zwavejs integration.
You need to enable the Home Assistant ws integration in zwavejs2mqtt if I recall correctly. I do not recall if you need to fill in the hostname field.

Yep… got that set…

and have tried setting it here in the Supervisor==> Add On ==>
here in configuration

its not persisting…

i had it working earlier on my test machine and am going by memory. I do not currently have that set up , unfortunately.

Thats ok… you’ve been allot of help…

I mean everything is working… so I should prolly just let it go… If it aint broke…

1 Like

That’s not where it goes, it goes in the integration. That’s the addon

1 Like

Petro… Agreed it was… But the only place I could find… from the integration page… Stems from my original post question… Should I have a JS2MQTT card on the Configuration ==> Integrations ==> page?

How do I get it into the JS2MQTT integration?


No, you use the zwave js integration. It’s covered on step 11 of the guide you linked

1 Like

Ahhh… Not IN the integration… After installation…but in the integration DURING Integration installation… Ok… that was done… which explains why things are working as expected… Context is everything
Step 11.


  1. No I should NOT have a JS2MQTT integration card on my integrations page. Only the Z-Wave JS card should be there.
  2. Connecting to the Websocket on port 3000 is accomplished DURING installation… and only then…as per step 11 in the guide.
1 Like