Should I change my Zigbee Channel

With WiFi on 1 and 6 you should bring your Zigbee channel to 20+ for least interference.

Zigbee 15 sits exactly in the middle of WiFi 1 and 6 so a lot of interference from both sides of the spectrum.

1 Like

Little update on my zigbee network. Moving the mesh node worked a treat. Not had an issue for 10 days now. So if you have a spread of wifi channels like I have make sure the nearest one to the coordinator is at the other end of of the channel scale to the coordinator.

Thanks for giving feedback.
Good to hear removing the WiFi/Zigbee spectrum interference has resolved the issues for you!

Hi All,
Just got a new Sonoff Zigbee 3.0 Stick.
I planned to place it on channel 25 (no Wi-Fi there).
I use ZHA, but cannot find how/where I can set/change the channel.


Hey, if you search Home Assistant Zigbee channel, you will get heaps of links. This is the official HA link
Zigbee Home Automation - Home Assistant.

1 Like


Did use this after your help:

      channel: 25

Has worked fine.

Updated HA to 2022.9.0 yesterday.
After this my HA/ZHA think it found a new Radio on Channel 15 and want to migrate.

Others with the same issue?
Seems like the above configuration does not work anymore, but it was not mentioned in “Breaking Changes”


So is this s new fresh install.

What I found was you need to whip the ZigBee stick by flashing it

It took me a couple of goes to get that channel to work.

Have you updated the firmware on the stick?

Hi Apples,
The stick is flashed with firmware from Z-Stack-firmware/coordinator/Z-Stack_3.x.0/bin at master · Koenkk/Z-Stack-firmware · GitHub

If the stick realy was on Channel 25 in 2022.8 versions of HA i dont know, but it is now with versions 2022.9.0 and 2022.9.1 I get this info.

But the stick still works.


Can you post a screenshot of it wanting to migrate that channel??


Migrate Radio is used to migrate to a new ZigBee coordinator and have nothing to do with your channel

Hi Sesame26,
I understood that afterwords, but have you any idea why my radio is on channel 15 when I specify in the configuration that I want it to be on channel 25?

A related couple of questions, as I am trying to diagnose some switch drop outs on my zigbee network - hopefully someone can help:
a.) is there good free-ware tools to analyse wireless networks (currently using something by ambeent - but it doesn’t show zigbee, just wifi)

b.) where do I find what channel my zha coordinator is running on (assume 15 but want to check) - its a sonoff dongle

Thanks in advance…

AseKarlsson - where do you get access to that info… ??

See picture above, taken from Settings, Devices & Services / ZHA

15 is the default channel chisen by ZHA. Adding the channel you prefer to the config is not enough as the channel only gets picked up when you form a new mesh network. I moved to ch25 a while back and forget exactly how I did it, but it was something along the lines of backing up the stick, editing the backup and booting it back up. This was to avoid having to re-pair everything. I thought ZHA had now implemented some way to change channel more easily… but I never looked into it given everything works great now that I am on ch25

Just keep in mind, that you can have a happy wifi 2.4ghz if you only use 1,6 or 1,11 6,11 just always change/switch the channel on the closest ap. If you have a “better” AP you can asewell lower the power of the AP since its anyway stronger than most of the connected clients, so your phone might see the WIFI but is to weak to send anything there. By lowering the powe of the APs you minimize the interferance a lot aswell.
In my case, changing my Channels to 6,11 was way easier, than migrate my zigbee to channel 25 (its on 11 atm, so wifi channel 1) so i did not have to repair everything.

Regardless, read and try to follow all the best practices and tips here → Guide for Zigbee interference avoidance and network range/coverage optimization

I only see this notification on HASS start up, is there someway to monitoring this channel util all the time? In a sensor or something?

Zigbee channel 15 utilization is 91.06%!

As far as I can tell, these numbers that ZHA spits out are total garbage. Without very expensive monitoring devices and knowledgeable person, there is no way to see bandwidth usage. And even if a particular segment of the bandwidth had high utilization and you are having zigbee issues and are in that same band, the problems are probably not due to high utilization but rather some other issues in zigbee devices and/or routing.

If you are going to change your channel, which requires a rebuild of your zigbee network, IMHO, you should rip out ZHA and move the Zigbee2MQTT.

I think the message you have cited has caused a number of people to make a good zigbee network bad or a problematic zigbee network worse. And wasted a lot of folks time, money and made useful home automation via Home Assistant look bad in the eyes of the ‘significant others’ that we try to help with this stuff.

Removing ZHA from your Home Automation system is the best move to make. Good hunting!