Should I upgrade to RPi4 or use a VM machine?

I use a RPI4 since 5 months (4GB model) without any hassle.

Running these Addons:

  • Configurator
  • ESPHome
  • Glances
  • Mosquitto Broker
  • Pi-Hole
  • Portainer
  • SSH & Web Terminal
  • WireGuard

and developing some addons on this system.
Pretty beefy the RPI 4 :slight_smile:

The only flaw in my opinion is the SD card which can get corrupted, to deal with this case I regularly take snapshots and sync them to my NAS

Thanks for you input. In average, how much time does it take to restart? The SD card issue is one of the main reasons I haven’t switched to the RPi4, it happened to me once already with my current configuration. I had backups but still a hassle.

Wow !

Talk about throwing a handgrenade into a room full of extremists …

“Now Gathered Clerics of ALL the world’s Religions … What is the best Religion and Why ?” :rofl:

1 Like

:rofl: Good point, but it has not been too bad.

I’m running USB Passthrough just fine using both the HUSBZB-1 and Aeotec Z-Wave stick on my Workstation 15 VM running on my Server 2012 R2 box. The only issue I have is that every so often after a reboot the /dev/ path will change from 0 to 1 or vice-versa. Only takes a quick comment and uncomment in my config and a restart and things are back to normal.

What @ab0tj said, if you have 24/7 hardware already there’s no point in spending any extra and so much faster than a Pi.

Disaster recovery is a two minute job if you back up the VM and easy to have multiple versions if you want to trial new things.

I run VMWare on my HTPC/server/anything else i can think of running with Windows 10 as the host OS and use a Zigbee stick with it with zero problems other than the initial release version of the VDMK helpfully didn’t have the USB passthrough enabled in HassOS, simple update of HassOS and been fine since, far more stable than the Pi3 I used previously.

If your offered the device named path too, eg /dev/serial/by-id/usb-Texas_Instruments_TI_CC2531_USB_CDC_etc, use that instead and you shouldn’t get that problem anymore.


A little bit late to the conversation, but I also use an NUC.

It’s an i3 from 2013, 8GB RAM and 120GB SSD. It runs Ubuntu Server with Docker and it’s blazing fast!

Never had a problem.

I think NUCs from 2013 you can get for pretty cheap.

Another NUC user here. Went from RPi3+ -> VM -> NUC. I run HA within Docker as well.

I prefer the NUC for one big reason: you can now multi-task it, run other applications such as Pi-hole, etc, and you won’t have to worry about overtaxing it like an RPi. RPi’s are good for single purpose apps, but not so much in the multi-tasking aspects. Plus, I had so many SD corruption issues with my RPi3+ that I gave up.

Just look for tutorials on how to pass through usb devices or usb controllers for your platform. I run Unraid and found a YouTube video explaining in detail how to pass one of the 2 or 3 usb controller segments to my Hassio on Ubuntu Server VM.

You can install HassOS in a VM if you want to keep your environment the same as they are on your Pi.

Edit: I’d also say that a Raspberry Pi 4 should be a quality upgrade for you. Downsides: the Pi route comes with the risk of data loss when the SD card wears out, and as you add more devices you won’t have as much room to grow as you probably would on a VM.

I gave that a shot at first but never got it to work. I may give it a shot again, but for now if it ain’t broke…

Create a udev rule to map the stick to a fixed path. Check this link from the z-wave docs.

I’m running hassio on a VM on an i3 NUC running ESXi. 16GB ram, 240GB SSD. using a conbee2 passed through to it.

No trouble with it. Reboots in 30 seconds or so (I think) It’s far faster than the PI.

And you get the benefits of snapshots before upgrades.

I’m also running a bunch of other VMs on it for other things. Like a separate VM for mqtt. (and another to handle cert renewal.)

A restart of the homeassistant container (via HomeAssistant GUI) takes 36 seconds
The restart of the whole RPI takes 2min 57 seconds.

For me thats ok because I dont often need restarts

I run HA on Synology in docker, works perfect :+1:

I upgraded from Pi 3B to Pi 4B 4GB.
Pi 4 in an all-heatsink fanless enclosure. It now runs like a dream.

But in the upgrade process, I’ve made a few changes, which no doubt helped:

  • Switched from Raspbian venv install to HassIO generic Linux install, still Raspbian.
  • Switched to the MariaDB addon (which sped up history and logs considerably)
  • Using RAMDisk on the 4GB RAM for Addons, Config, tmp folders and /var/log.
    In total, 3GB allocated to RAMdisk. Stable at less 1.5GB utilisation at the moment.
    As far as I can see, no more small constant writes to the SD card. Ensuring longevity.

Reboot takes a while because it has to write back all changes on RAMdisks (1-2 min), and reload over 1GB of data on boot up (a few minutes). But I don’t reboot the whole system often enough to be bogged down.
HA and addons restart quickly.

1 Like

I like the idea of using a RPi4 but I don’t want to deal with SD cards’ corruption. Did you install the image found at:

Thanks for your input.

I’m using Raspbian image off official Raspberry pi website.
Then followed these instructions to get “Home Assistant” (formerly HassIO) up and running:

This allows me to run custom scripts and other applications in the generic Linux environment. Such as use log2ram program for /var/log, set up RAMdisks for HassIO folders. Latter is based on the same idea as log2ram, using scripts written by myself.


:rofl: :rofl: :rofl:

1 Like

Intel Nuc running proxmox hypervisor so I can run other vm’s at the same time.

I love my pi but this was a good investment for me.

Note after doing this if you still want better performance from logs, change your DB from the default to Maria. Some of the slowness was not the PI at all, but rather the default db. Now it’s fast like it should be.

1 Like