Simplified Zwave Lock Manager is now KeyMaster

Try making your own fold entity row entry in a new Lovelace page. You probably have some other issue as why it’s not working.

Post your code here. I might add that to the package. I’m due for an update and might get to it this weekend.

I might look into the fold-entity-row at a later point in time. For now, here are the template sensors I snagged from ptdalen:

- platform: template

      friendly_name: 'Schlage Battery Level'
      value_template: "{% if states.zwave.lock_front_door_deadbolt %}
          {{ states.zwave.lock_front_door_deadbolt.attributes.battery_level }}
        {% else %}
        {% endif %}"
      unit_of_measurement: '%'
      icon_template: >-
        {% set battery_level = states('sensor.door_lock_batteries_front_door')|int('unknown') %}
        {% set battery_round = (battery_level|int / 10)|int * 10 %}
        {% if battery_level == 'unknown' %}
        {% else %}
          {% if battery_round >= 100 %}
          {% elif battery_round > 0 %}
            mdi:battery-{{ battery_round }}
          {% else %}
          {% endif %}
        {% endif %}
      friendly_name: 'Last Keypad Unlock'
      value_template: >
        {% set number = states('sensor.lock_front_door_deadbolt_alarm_level') %}
        {% set entity_id = 'input_text.frontdoor_name_' + number %}
        {% set user = 'Master' if number == '0' else states(entity_id) %}
        {{ user }}

Thanks. I’ll add this to the package.

1 Like

I’m waiting on my Schlage to come in and was looking for a way to manage it with home assistant. I’m new to this so I wanted to just verify that each yaml is a code slot for each code I want to use? So if I wanted to fill the 30, I would need 30 yaml files?

I’d like to add the clock time to the notification message when the door is locked or unlocked. I’m not sure where to add this string to the notification automation to get that to come across {{states(‘sensor.time_date’)}} in the notification. I’m using the Ariela app for notifications and it doesn’t include the time on the notification by default so I’d like it to come through in the notification text itself.

I know how to do that in regular notification messages, but I’ve never done it then the message is a template.

Any help is appreciated!

I have been able to set this up but the pin is not being transferred to the lock, The status shows connected.

Am I missing something?

Yes, you would need 30. But you can modify the setup script to create 30 slots. You would have to manually modify the Lovelace to add them, but it shouldn’t be difficult.

If it shows “connected” the PIN should be in the lock. See if you can use the services tab in Developer Tools to manually set the pin there. If that doesn’t work there, you will have to solve that problem before this package will work.

Yes I was able to set a code via the lock.set_usercode
Initially the node_id was set to 18 but the actual node_id of the lock is 16. Do I need to change this somewhere in your package?

I am not sure if it makes a difference but I have the Zwave Plus version of this lock, I did rename all of the entities as you laid out in the instructions

1 Like

Sounds like the node id might have changed. Did you delete and then re add the lock? Changing the nodeID is worth a try.

I’m about to publish a new version to fix a bug, but go ahead and experiment as I don’t know when I’m going to publish the update

I haven’t deleted then re added it, do you mean completely removing it from the Zwave panel?

How do I change the nodeID to match what mine is currently set too (16)

I haven’t looked at the code in a while, but I don’t think you need to change the nodeID at all. You need to make sure the name of the zwave lock matches what is in the code.

This package uses a Schlage BE469 Z-Wave Door lock and an (optional) Monoprice Z-Wave Plus Recessed Door/Window Sensor (Model #15268) door sensor. If you aren’t using the Monoprice or similar open/closed door sensor, you can just hide the assoicated entities in Lovelace.

N.B. When you add the devices to your Z-Wvave network via the inlusion mode, use the Home Assistant Entity Registry and rename each entity that belongs to the device and append _frontdoor to it. For example:

zwave.vision_security_zd2105us_5_recessed_door_window_sensor would be renamed to zwave.vision_security_zd2105us_5_recessed_door_window_sensor_frontdoor
sensor.schlage_allegion_be469_touchscreen_deadbolt_alarm_level would be renamed to sensor.schlage_allegion_be469_touchscreen_deadbolt_alarm_level_frontdoor

Just to be safe, you should rename every entity in the entity registry. The easiest thing to do is to paste _frontdoor after each item in the registry. Do a global search for the “base” name and make sure everything looks correct. So for the Schlage BE469, that would be schlage_allegion_be469_touchscreen_deadbolt, and for the Monoprice door sensor, that is vision_security_zd2105us_5_recessed_door_window_sensor.

Double and triple check you renamed the lock entities correctly.

I just finished checking again, kindly have a look and let me know if you see anything

I appreciate you helping here, I am so close lol

I just went through the lock_manager_common.yaml in an attempt to trouble shoot this. I had renamed all the sensors but these 2 items got me a little confused. Are they named correctly?

The first post says it expects your lock’s entity_id to be lock.front_door_lock but the lock_manager_common.yaml seems to have it set as lock.schlage_allegion_be469_touchscreen_deadbolt_locked_frontdoor

Try doing a search and replace in the lock_manager_common.yaml and replace it with your entity_id.

Thank you,

That was exactly the conclusion I came too, I just wanted to check. I guess I could always change my current entity_id from lock.front_door_lock to lock.schlage_allegion_be469_touchscreen_deadbolt_locked_frontdoor

I fixed it !!

I changed the entity_id of the lock to lock.schlage_allegion_be469_touchscreen_deadbolt_locked_frontdoor

And it worked 1st time, I am thrilled with this :grinning::grinning::grinning:

A big thank you to Future Tense for initially sharing this project. Everyday I learn a little more about Home Assistant

I had the same issue when I first installed everything. I found moving the fold-entity-row.js outside of it’s original installation folder worked. I changed reference in the RAW Config editor as well.


Hope this helps,

There is an error in my instructions? Please narrow it down for me and I’ll try and fix it. I’m about to publish an update which fixes a bug with the timed entry points for each day of the week.