Simplisafe alarm requiring code and I don't want it to

I am not sure if this is a Simplisafe integration issue, or a user error.

I totally started over this weekend with a fresh install, reset all of my devices & integrations. I have been running hassio in Docker and I went with the Proxmox install and I am now getting around to rebuilding all of my automations, and integrations.

One of the most annoying problems I have come upon so far is my Simplisafe. Last week I had a card with the status icon and Arm Home, Arm Away - or Disarm buttons only. No keypad. I can not get it back that way. I understand the risk, but I have no wall panels or remote users. I have automations that depend on being able to arm/disarm the alarm without the code. I also want the minimalist card in Lovelace.

What I have tried so far:

  • Entered a specific code in configuration setup by adding integration - (Didn’t work)

  • Made a new entry in configuration.yaml file (Didn’t Work):

    - username: !secret simplisafe_username
      password: !secret simplisafe_password
      code: !secret simplisafe_code
  • Configuration > Customization > Entities > (alarm) > code_arm_required : changed to false (Didn’t stick or work)

I have run out of ideas. I have tried all of the tricks I have found by googling and searching this forum.

Thanks in advance.

Did you try leaving out the last line starting with code: ?
The docs say it’s optional.

It is getting a bit comical. I now can not edit my configuration.yaml through the file editor. It is giving me this error:

[Errno 30] Read-only file system: '/config/configuration.yaml

I think I am about ready to go back to the Hassio running in docker on Ubuntu server. I really want to like the Proxmox, I just am not smart enough for this setup. Supervised install on docker may not be officially supported but it was sure easier to use.

I think I will tackle the permission issues now, and then worry about simplisafe!

Thanks for the help.

Don’t give up so fast :slight_smile: I switched to a Proxmox setup more than 2 years ago and it’s one of the best things I did in my opinion.
Are you currently running the Proxmox image?

Yes. I am using the Whiskerz007 script version currently.

I took a pretty recent mac mini and took the spinney drive out and replaced it with an ssd and installed Proxmox. It was nearly too easy. I used this walkthrough: Installing Home Assistant using Proxmox

I couldn’t change the static ip address, and used the hassos command line to change it. It totally messed up my install. I used this walkthrough for my second install: Supervised Install on Proxmox. It then quit booting. I then took GParted and wiped my drive and went back to the first one using the Whiskerz007 script. It has been stable and working well. The biggest problem I am having is my lack of understanding. I understand the concepts, but have a hard time implementing it.

I will stay with Proxmox for now. I really liked the Docker setup better as I had static files outside the container and I had more control since it was just an Ubuntu server (I have a tiny bit more knowledge of Ubuntu, than I do Proxmox)

Just to make things clear, if you run a supervised version (add-ons, supervisor tab, etc. available) then you are running in docker anyway. The only option that doesn’t run in docker is installing Home Assistant Core in a virtual environment.

I use Proxmox as well, with multiple Home Assistant VMs. One VM (production) runs Ubuntu and Home Assistant Core in docker on top (no add-ons, etc., called Home Assistant Container now). The second VM (“development”) runs Ubuntu as well and Home Assistant Core is directly installed in a virtual environment. The third VM (testing) runs Ubuntu and Home Assistant Supervised with add-ons etc. available on top (the not officially supported install on a generic linux machine).

From your post, I assume it would be the best for you to install Ubuntu Server in a Proxmox VM and then install Home Assistamt Supervised on top (the not officialy supported install method). I suggest this guide

Ok, I like that. If I am reading correctly, it is pulling the current dockerfile from official sources. If I am not mistaken the hassio dockerfile I was running was maintained by someone else. That really makes it look appealing. I see that it has instructions for Debian, or Ubuntu.

Awesome. Thank you for the link.

1 Like

Sounds as what you had was a script that sent the code and the buttons in your Lovelace was just buttons to activate the script(s).

I have an automation that arms the the alarm (not simplisafe), call service on the alarm, entity is the alarm panel, the data:

code: 1234

And that works fine.

I don’t remember ever setting that up. It has been running for over a year, and I don’t remember what I ate for breakfast.

That sounds like a good workaround though. I could just make my own card.

Thank you!

It’s so much more fun when you don’t remember.

Imagine how boring it would be of you remembered the mess the kids left behind them.

I do sales for a world-wide industrial automation supplier. My poor memory can cause me a lot of problems. I don’t think I have a bad memory, only so much room in my pea brain to hold data. When something comes in one end something leaves the other.

1 Like

If there remains a SimpliSafe issue, feel free to open a new bug report.

Thanks! I am not sure what is the issue simplisafe or something else. I just nuked my install (intentionally) and will see if it does it on this install.

1 Like