Sky Q set-top box custom media_player component

Just checked again and it’s changed again, seems to be a regular thing by the looks of it.

Yeah, this might be a bit of an issue. See edits to the OP.

To correct my previous statement - my mini box has never changed it’s always been description0. My silver box alternates between description1 and description2, haven’t managed to find any pattern yet.

Did the websocket been closed off in latest software version?
the scripts on 5900 are no longer working?


Forgive me, but I appear to be missing something, I’m just starting out with HA, and have a few skyQ boxes, but following this thread I fail to see where I can get the file from.


1 Like

is there any plan / possibility of this becoming available again?

Does it work for a standard (newer version) PlusHD box?

Im also very frustrated that my Sky box is the only (and most used) media aspect missing from HAS!!!

1 Like

I think the ports on Sky q are now blocked. Been timing out a few weeks ago. Haven’t checked this week but doubt they are open again. As for HD there are some articles about ports and api on Google.

Looks like the port has just moved to 49160.

Thanks that works a treat.
It’s been 2 weeks without working.
Sky Q.

Guys where do i place the port number 49160?

Looks like the latest update (Q060.000.29.00L) has killed this. No longer works on port 49153 or 49160 - sky box drops the connection straight away, that’s on my 2tb silver box, looking at my mini though that’s on the same version and still works fine and responds ok on port 49153.

Rebooted my 2tb silver box and working fine on 49153 so looks like they have moved it back??

Hi, Is there any chance of the file being made available again?
Many Thanks

I second that. Would be great to play around with.

Very interested in the status of this component / availability of too. This looks like a great enhancement to HomeAssistant.


I’ve tried to follow this thread and install the bits and bobs mentioned, but when checking my config i get:

2018-02-21 21:17:03 ERROR (MainThread) [homeassistant.loader] Error loading custom_components.media_player.skyq. Make sure all dependencies are installed

what are all of the dependancies needed? ive installed pytz, ws4py & xmltodict

EDIT: ahh, its telling me ws4py isnt installed, but ive just done it!?

core-ssh:~# pip3 install ws4py
Requirement already satisfied: ws4py in /usr/lib/python3.6/site-packages

I had to install ws4py.

It was then complaining about xml.parsers.expat.ExpatError for me, and adding an import xml at line 20 fixed it.

Working beautifully now. It’s a great addition to Home Assistant but it’s a shame that Sky don’t expose more functionality (e.g. control).

@dandowftm I’m pretty new to HomeAssistant, but isn’t that core-ssh: prompt that you have My understanding is that you can’t install python dependencies independently like that with Hassio, but instead would have to package up a Hassio add-on (as described at

Hi, yeah I think thats the case. I’m new to it all too, but did read yesterday that if I install hassbian rather than Hassio I can do it this way, does that sound correct?

Yes, I believe you’re correct. The server on which I have working is actually set up as development server, as I want to try developing some custom components for HomeAssistant - but I believe Hassbian would be similar from an ‘installing python dependencies’ perspective.