SMA Inverter + Home Manager 2.0

I recently installed SMA Inverter 10000TL along with Home Manager 2.0 and I chose SMA after noticing a large number of HA community using the same inverter. I want to get the data from sunny portal. I have tried to follow the instructions on the SMA components page ( but with no luck so far.

While trying to troubleshoot, I tried to directly access the Inverter & Home Manager using local ip in the browser but no webpage opens. It says ‘refused to connect’. However, I can view the data using webpage.

      - platform: sma
        group: user
        password: my_pass
        scan_interval: 120

Please format your pasted configuration correctly. See step 11: How to help us help you - or How to ask a good question

I think I found something, but I have no idea how to fix it.
Module SMA should be set ast default to SSL: false
Even I set this in config as FALSE, then in log I can see that SMA module tries to connect via SSL anyhow…

Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/components/sma/”, line 128, in async_sma
values = await
File “/usr/local/lib/python3.7/site-packages/pysma/”, line 240, in read
yield from self.new_session()
File “/usr/local/lib/python3.7/site-packages/pysma/”, line 211, in new_session
body = yield from self._fetch_json(URL_LOGIN, self._new_session_data)
File “/usr/local/lib/python3.7/site-packages/pysma/”, line 201, in _fetch_json
self._url + url, **params)
File “/usr/local/lib/python3.7/site-packages/aiohttp/”, line 476, in _request
File “/usr/local/lib/python3.7/site-packages/aiohttp/”, line 522, in connect
proto = await self._create_connection(req, traces, timeout)
File “/usr/local/lib/python3.7/site-packages/aiohttp/”, line 854, in _create_connection
req, traces, timeout)
File “/usr/local/lib/python3.7/site-packages/aiohttp/”, line 992, in _create_direct_connection
raise last_exc
File “/usr/local/lib/python3.7/site-packages/aiohttp/”, line 974, in _create_direct_connection
req=req, client_error=client_error)
File “/usr/local/lib/python3.7/site-packages/aiohttp/”, line 927, in _wrap_create_connection
req.connection_key, exc) from exc
aiohttp.client_exceptions.ClientConnectorCertificateError: Cannot connect to host ssl:True [SSLCertVerificationError: (1, ‘[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1056)’)]

are there any news from this tryout ? i want to log mein Tripower Inverters through the HomeManager 2 in Hass but so far no luck .

I always get this notofication :
2020-01-01 16:21:49 ERROR (MainThread) [pysma] Could not start session, Could not connect to SMA at (timeout), got {‘err’: ‘Could not connect to SMA at (timeout)’}

I have no issues reading mine using the IP. I have however never managed to add this to HA as it always mentions ‘unable to connect’ in the logs.

Anyone figured out if this works? I cant get any data from this, wonder is this really only for USA ( The sma sensor will poll a [SMA] [(US)] solar inverter) or can it be used elsewhere and if so how?