Solaredge Modbus Configuration for Single Inverter and Battery

I would just leave that option turned off then.

It’s possible never closing the connection triggers a bug in the firmware version for your inverter like a memory leak or something with long connections.

Even with it off there seems to be an issue, although possibly not as bad. I’ll take a look at logs when I have time.

You should see a difference at least with retry attempts when it times out.

I’ve uploaded a new log file to the same link as previously. This covers a day with v2.4.11-pre.1 and Keep Modbus Open set to off. It’s worked throughout the day, but there have been some slow connection times and a number of times where data refresh attempts have hit 4. At present it seems to have survived with Keep Modbus Open set to off. I’ll keep an eye on things for now.

Thanks for the help.

I just uploaded Release v2.4.11-pre.2 to try and address another report about timeouts. This version reduces the size of some modbus reads.

I’ve installed v2.4.11-pre.4 now - I’ll keep an eye on it.

Pre-releases 2-6 turned out to be chasing the wrong issue.

Release 2.4.11-pre.7 goes back to .1 but removes the internal requirement to keep the modbus connection open for polling intervals less than 10 seconds.

It seems like all of these problems with timeouts can be traced back to the keep modbus connection open option and the inverter response becoming slower over time as the number of reads increases without closing the connection. I don’t see this problem personally, but my inverters are running firmware 4.0014.0229 so if this is a problem with newer inverter firmware versions I won’t see it.

So basically if anyone is having timeout issues make sure the “Keep Modbus Connection Open” is turned off. I recommend it be kept off anyway unless there is a specific problem that it helps with.

1 Like

Ok - I’ll try v2.4.11-pre.7 with Keep Open off and see what happens. I’ve continued to have issues with v2.4.11-pre.4 - better but still losing the connection after some time.

Hi! I was thinking for an automation for increase the “reserve” battery in winter, and not allow to be fully drained for too much time (if we swing from 50% to 0% it’s the same to swing from 100% to 50%, but increasing the life of the battery). I’ve seen some ideas here, but i was thinking for something automatic.
I was thinking to detect the prolonged usage at low battery levels in 2 ways:

  1. If average battery % of n days is under a value
    Or
  2. If average time spent of last n days at the minimum % is over a predefined amount.
    The system activate an automatism, that if the next day (after n days) is still under the percentage, it increase the % limit by 5%. Else decrease it.
    In this way the average battery % (or time spent at low %) increase, and the system “autocalibrate”.
    If 1. Or 2. Are not met for 7 consecutive days, the day counter will reset, and the depth of discharge is reset to it’s defualt value.

Seem a good logic?

1 Like

Quick update - still getting lost connections, not as frequently, but still happening. I’ve put the latest logs on the Shared folder if they help at all.

The config is currently as:

When I get this repair, when I click though I always get issue repaired.
image

Even when the inverter is offline.
image

Is it possible for the repair dialog to verify that it has restored communications?

The repair dialog only pushes a settings update to Home Assistant, it doesn’t do anything to restore a connection.