(Solved) Energy Dashboard stopped working with upgrade to 2022.2.0

Hi Alessandro,

thanks for pointing me in the right direction
When searching in the configuration.yaml i found these statements:

    last_reset: '1970-01-01T00:00:00+00:00'
    device_class: energy
    state_class: measurement

After comment these lines out with a # the energy dashboard start working again.
I don’t know why and how these lines came in the configuration.
But the most importing in this case is that the problem is solved.

Many thanks again.

I told you. :wink:

Glad you solved it, take care.

Hi all,

Information provided in this thread helped me to solve the energy dashboard problems and I thank you all.

Now I have another problem with the data that energy dashboard is showing.

First I have a 10kW solar system installed and I retrieve data form the logger via a comand_line platform:

  - platform: command_line  
    command: curl -s -u admin:admin | grep -E "\webdata_now_p(\s|$)" | cut -d'"' -f 2
    name: power_solar_now
    unit_of_measurement: 'W'
    scan_interval: 30
  - platform: command_line  
    command: curl -s -u admin:admin | grep -E "\webdata_total_e(\s|$)" | cut -d'"' -f 2
    name: solar_energy_total
    unit_of_measurement: 'kWh'
    scan_interval: 300
  - platform: command_line  
    command: curl -s -u admin:admin | grep -E "\webdata_today_e(\s|$)" | cut -d'"' -f 2
    name: solar_energy_today
    unit_of_measurement: 'kWh'
    scan_interval: 60

After this I have a template sensor that I use in energy dashboard to add the device_class and state_class:

  - sensor:
    - name: "energy_production_today"
      state: "{{ states('sensor.solar_energy_today')}}"
      device_class: energy
      state_class: total_increasing
#     state_class: measurement
      unit_of_measurement: "kWh"

Problem is:

For example today 27.02.2022 energy production is 7.23kWh

This is from the inverter webpage


But is the energy dashboard solar production is 19.7kWh


Dos anyone have this issue?

similar problem. My sensors are all total or total_increasing but the whole dashboard shows nothing

I’m having a similar problem now as well.

After months of working without issue, all of my values are now 0 kWh. Very frustrating…

This was last week:

Each of the sensors are set to ‘total’, which I believe is correct.

state_class: total
unit_of_measurement: kWh
attribution: Data provided by Sense.com
device_class: energy
friendly_name: Daily To Grid
last_reset: '2023-06-05T06:00:00+00:00'

Is anyone else experiencing this problem?

Edit: this appears to have been an issue with my Sense meter. The daily production values were outputting zero as it had a minor connection disruption a few days ago. I’ve corrected it, but now there’s a new problem with my Energy Dashboard reading some bad data that I’m trying to troubleshoot.