[SOLVED] Hassio on docker --- failed to start after 106.5

Hello everyone ,
Thanks for the tip , it’s ok for me with recreation with last image :slight_smile:
Thanks a lot

@Anwen I had this exact same error and it was the only error in the log. The Core container wouldn’t start, but everything else was up. I am running on a raspberry pi. I just found that folder and renamed it, then rebooted and now the Core container starts up.

1 Like

Oh, thanks for letting me know! I’m going to try to find that folder.

Edited to add: I’m not finding that folder…could you tell me how you found it, and exactly how you renamed it? Thanks so much!

I’m getting the same issue.

Client error on Websocket API Cannot connect to host ssl:False [Connection refused].

Tried the above steps, removing the supervisor docker image, trying to re-install, rolling back to supervisor 206. But still no go.

Is it safe to delete the supervisor container AND the image ?
Thats about the only thing i havent yet tried!

Out of interest, i rebooted the host again, as last time i did it was on supervisor 207.
Now that its on 208, im now getting an actual useful error:

ERROR (MainThread) [supervisor.homeassistant] Home Assistant can't write pulse/client.config: [Errno 21] Is a directory: '/data/tmp/homeassistant_pulse'

To me this looks like an issue others have had where the audio group doesnt exist, but in my case it does. Seems atleast a step in the right direction.

I tried that, it didn’t help me.

Everything was recreated, but the error still persists. The Home Assistant image is created, but is shown as unused in Portainer.

I pulled the SD card out of my pi and mounted the “data” partition, and it was under /tmp. Not sure that helps you…


I have success!

I found the folder in /usr/share/hassio/tmp … i moved the folder homeassisant_pulse out of the way.
I restarted the supervisor, but it didnt do anything.

Last ditch attempt – i restarted the host, and now its all back again!


This also worked for me.

1 Like

And for me! I’m a happy camper right now! I think we were all finding the same solution at the same time! Just FYI, there is GitHub issue here that helped me figure out exactly where to find the directory.

Thanks very much to all of you for your help in figuring this out! :star:

As part of this i rolled back to a snapshot on 0.106.2 — am i game to update to 0.106.5 now? :smiley:

There was obviously some kind of underlying supervisor issue too (or my nuc needed a reboot) as ha restarts were taking up to 5 mins before this all happened, and i just restarted in under a minute.

Yes, I’m on 106.5 and supervisor 208. All seems fine.

Yeh i bit the bullet and upgraded — all good!