[SOLVED] HASSOS mount NAS network share

Hmm but as from what i can see it is making folder outside the media folder :thinking:
Why are you using integration?

Maybe you need to do this?

Put inside media folder? like this:

    local: /media/frigateint
    recording: /media/frigateint/recordings

I am just guessing

integration is more important to me than the add-on as i use it for automation based on object detection from frigate (e.g lights turn on when person detected) etc.

But you can use it even with addon. I am using it for perimetr person alarm :slight_smile: I am using MQTT to read detection

Hello All, just to provide an update. HAOS has been working flawlessly for a few days. I have frigate add-on v0.11.0 and Integration v3.0.0 installed. My NAS now has 400GB worth of footage. My HAOS storage has still been at 45% (not changing) my VM backup has been consistently at 17GB. I my auto-backups in HAOS and Proxmox are working as expected (am just excluding the Media Folder). It just sorted out itself for some reason. The only thing different I did was to uninstall frigate add on and integration , reboot supervisor and installed again frigate. must be some incorrect directory structure from the old backup. thanks to this Forum and special thanks to Ukro for helping out!!

1 Like

Hi all

I’m using HA in a Proxmox VM, how can I use a NAS shared folder and, possibly, available also in the addons ?

I’ve used this script to install HA in a Proxmox VM


you should manage to go through my tutorial and do all the necessary steps.
Let me know if you will be having problems.
I didn’t updated the script yet, so you would need to download a updated script from github from dev branch. I hope will find some time and update it to the main branch :slight_smile:

Sorry to bother you, but I haven’t understood the process.

Actually I have a Proxmox VE with HA installed in a VM.

I read you first post and also the Readme on Github regarding the script in the dev branch

This script have to run in a separate Linux environment other that the Proxmox server or any other VM or CT in it, right?

I see in the script that I have to choose the NAS IP and folder and then the device (sda/sdb/sdc/sdb), which device is this and how to get this info?

Thanks for your help!

Actually I’m trying two different Frigate installation and I will choose which will fit the best for my needs.
I have the HA addon (HA is installed in a Proxmox VM) and, on another server, I have installed it as a Proxmox CT following the instruction found in the Frigate docs.
Of course, only one Frigate is running, alternatively.

In both case, I have defined my NAS folders as mount point storage in Proxmox, at Datacenter level.

Maybe it’s easier to use the NAS storage in the CT rather than in the VM, correct?

What do you suggest?

If you are able to run it on CT then go for it as you can mount it easier from my understanding.
But i have it in a VM. With CT i had problem that i cant access my frigate through https external nabucasa cloud. So i went with VM. It really depends if you are okay with CT :slight_smile: Let me know if you will decide for VM, will give you some clues to go for. P.S. i am still not able to get my time together and update the script on main branch github, so i will help you with it. Or if you want, we can talk on whataspp if you PM your mob number. It will be faster than write.

I have solved this way.
I’ve mounted, in Proxmox Datacenter, my NAS folder in NFS.
Then in my Frigate CT I’ve added a mount point to it.
In the CT, with Portainer, I’ve adjusted the Frigate docker Volumes to the ones I needed, and now all seems to work
Only the db folder is local, because otherwise I get a db locked message.

Thanks for your suggestion!


This solution seems to be broken?
I followed the tutorial and it did work. Some days/restarts later It seems like Frigate /HAOS have reverted back to the Frigate folder on the HAOS install… (No more videos coming to the nas but reside in HA.

Latest version of both HAOS and Frigate at the time of writing.

Have you updated the OS recently? Each time you update the fstab gets overwritten…

1 Like

Ahh, thanks, that might be it.

Lots of great info here. Unfortunately I can’t get the mount to work. I followed the ukro’s steps exactly as indicated but the NAS share never mounts. When logged into the root I ran mount -a to try to force it to run and I get this error:

unkown filesystem type ‘cifs’

I get the same error when trying to run “mount -t cifs…” as well. Any thoughts? I’m running HomeAssistant OS as a VM in VMWare on a Windows machine.

You may not have cifs installed?


sudo modprobe cifs


apt-get install cifs-utils

I tried that but I get errors for each of those.

sudo modprobe cifs: sudo: not found
modprobe cifs: Module modprobe not found in directory /lib/modules/5.15.72
apt-get install cifs-utils: apt-get: not found

From what i tested it is not possible to mount manualy on host, only through fstab.

If you want, from thursday i will be @ home and can remotely connect and help you with it + skype. PM me if you need.

I tried the script just now with 22.11.4 and it didn’t work. Does it still work?

Hi, i have no time to update it to main branch and the image. If you take the script from dev branch, it should work. Let me know.