[Solved] Home Assistant Supervised on generic Linux - Host unreachable

I’m writing this topic so that it can be usefull for anyone who could have the same problem.
I’m using Home Assistant Supervised on generic Linux installed on KVM and https://virt-manager.org/

After a reboot I couldn’t reach port 8123 anymore. Nothing usefull was shown in the logs.
All containers where up and running.

After many (really many…and many more) attempts I’ve tried to remove all configurations and i restarted the host: the port was reachable again!

Note: since the supervised version uses net=host configuration the port is not exposed via docker but can bee seen in LISTEN mode with netstat.

Enabling all the configuration one at time and restarting everything every time, I’ve finally managed to see that the problem where:

  • the http block
  • the onvif camera configuration

Once adjusted the http block and removed the onvif configuration everything works again perfectly.

So, two notes: first of all, a better logging would be usefull but, nevertheless, if you are having this problem, try removing all configurations and enabling it back one after the other

Second: I’ve feared that the problme could be the Home Assistant Supervised installation beacuse of its deprecation. That was not the case.

But I want to say that the supervised installation is great! I’ve been using the raspeberry installation but after many (really too many) failures of the SD card I’ve decided to use a virtual machine on KVM. Things are great now! It is fast as hell and the backup is soooo easy! I love the supervised version of Hassio!

I’m still on the many many many attempts and still can’t get it stable. See description

I basically have a fresh install w/no integrations loaded. Id love to learn from your experience So any further details you can share would be great

Hi friendodevil.
I’m afraid I can be of no help. Your situation is quite different from mine. If I understand correctly, you’ve used the NUC image while I’ve used the ols home assistent supervised.

I’ve used this method: https://github.com/home-assistant/supervised-installer
I’ve installed a new ubuntu server and then I ran the installer script.

If you want to try the “old” method, take note that there could be a problem with the script: it has a missin ; at line 17. You should download it, and change the following lines:

if [ "$x" != "not supported" ]

with this single line:

if [ "$x" != "not supported" ]; then

then launch it.
And, obviously, install the required packages before launching it.

I did not use the NUC imag: I’ve used the VDI (x86_64/UEFI) image and booted it from Virt-Manager which is running on Ubuntu 20.04 on a NUC i5-6260U machine.

I guess you are running HA in a docker env in a generic Linux which is running in Virt-Manager, is that right?

Yes, but if I’ve understood, you’re running HasOS (https://github.com/home-assistant/operating-system) which is an embedded linux. While I’m using a default ubuntu/linux with a supervised installer: I’ve use the default ubuntu server image and launched the script I’ve mentioned in the previous post.
Mine and your are different installations. And while mine is deprecated (on hold), your is not.

I’ll give a try to your platform but, till now, I was unable to run it (I’ve tried the QCOW2 image).

I suspect it should be leaner and better performance to run HassOS in KVM with the benefit of Virt-Manager… Need to figure out how to get it stable. I did convert the VDI image to QCOW because I didn’t want to use the QCOW beta.

Btw: I have the HassOS set up working flawlessly for 15 months in VirtualBox, managing 18 devices and over 200 active entities

Let me know if you get it working