SOLVED: No TTS output from Google Home

Tags: #<Tag:0x00007f73ac7bf418>

Cool. Curious as to why you don’t use base_url in http component. Can you elaborate?

I was able to get it working by adding port forwarding 8123 > 8123

I had it commented out from over a year ago when I first setup HA and everything worked without it, not even sure what it does exactly, glad you got it working

I had the same issue. I had recently uncommented the base_url. Once I commented it out again, my TTS started working once more. I am using a Docker container.

I recently got this problem after adding home assistant behind an nginx reversed proxy. Fixed it by adding base_url in the tts section

HI, can you give me more information about configuration of nginx? wich home assistant version do you have?
I have Home Assistant Core 0.116.2 and when try to launch tts service i receive the error:

2020-10-18 18:43:39 ERROR (Thread-10) [homeassistant.components.cast.media_player] Failed to cast media http://<internal_IP>:8123/api/tts_proxy/6279886fde090b3038f267098bcca771a6efa946_en-us_a9c18110b0_cloud.mp3 from internal_url (http://<>internal_IP:8123). Please make sure the URL is: Reachable from the cast device and either a publicly resolvable hostname or an IP address

Here is my configuration. I’m running always the latest HA. I run this on Debian.

map $http_upgrade $connection_upgrade {
    default upgrade;
    ''      close;
}

server {
    # Update this line to be your domain
    listen 443;
    server_name homeassistant.yourdomain.something;

    # Ensure these lines point to your SSL certificate and key
    ssl_certificate /etc/letsencrypt/live/homeassistant......../fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/homeassistant......./privkey.pem;

    # Ensure this line points to your dhparams file
    ssl_dhparam /etc/nginx/ssl/dhparams.pem;


    # These shouldn't need to be changed
#    listen [::]:443 default_server ipv6only=off; # if your nginx version is >= 1.9.5 you can also add the "http2" flag here
    add_header Strict-Transport-Security "max-age=31536000; includeSubdomains";
    ssl on;
    ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    ssl_ciphers "EECDH,.................. More stuff.......RT:!DES:!MD5:!PSK:!RC4";
    ssl_prefer_server_ciphers on;
    ssl_session_cache shared:SSL:10m;
    
    proxy_buffering off;

    location / {
        proxy_pass http://127.0.0.1:8123;
        proxy_set_header Host $host;
        proxy_redirect http:// https://;
        proxy_http_version 1.1;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection $connection_upgrade;
    }

I dont know if its better also for my installation (ex HASS.io ) :frowning:

It does not matter. I use mine to get encryption and my own certificates. Also to use cnames.