[Solved] Problem with Tuya integration, MQTT config error strikes again?

@pk1966 you referring to a Tuya hub?

Looks like Tuya is going to charge for the API calls. I guess it’s now just a matter of time before all the vendors decide to bill-back end-users like us.

I sadly invested quite a bit in tuya stuff which has been working flawlessly until now. I can’t imagine a world where I would be paying a monthly fee to have cloud server turn on/off my lights, while I already have a server at home running home assistant…

Already cut that bridge with my not so smart garage door that didn’t integrate with anything (used ratgdo to control it with home assistant via esphome, which works like a charm).

Going to have to try the local tuya workarounds, or switch to something over zigbee / esphome.

Mine dropped out too,
Doing some digging, (unable to fine the article now,) I believe there may be a HA update about to drop with a major Tuya integration that will no longer require an Iot core API.
If this information is correct, there should be no need for the iot permission,

1 Like

Just noticed my Tuya devices not working when my scheduled tasks to turn on the lights at dusk didn’t work.

Did extending the trial work for anyone yet? Or do we need to wait for a HA update?

I following the instructions above by @DAB-LABS to extend my account:

CLOUD>CLOUD SERVICES>IOT CORE - VIEW DETAILS>EXTEND

And I see this on my page:

Just like some of you have said, expired since 2022 (probably when I created the account originally). I clicked the “Extend Trial Period”…not sure if that was the right spot or not. Applied for an extension of 6 months (the longest in the droplist of options). Now it says " Your application for extension is being reviewed. [Modify the application."

Give the upgraded tuya integration a try:

2 Likes

Tried the smart life integration hac, it’s awesome!

Yes, I had to reconfigure almost all my tuya entities in home assistant, but that wasn’t too painful as some were automagically migrated.
Their documentation states to use home assistant on docker setup, I have hassOs installed on a VM and worked like a charm.

1 Like

This Smart Life HACS integration worked for me too, working great again. Thanks!

Same problem here with Tuya api-key, Smart Life HACS integration works like a charm. Thanks!

Hey folks, FYI: They (Tuya) already extended my iot core services and my devices are back again!

I’m still waiting for them to extend my IOT core services, but have used this Joachim pointed out and it works very well - really easy to set up too!

I was thinking LocalTuya or TuyaLocal but the new Smart Life integration works well whilst I decide on my long-term choice.