[Solved] Setting up Bluetooth device tracker, Synology DSM7 and USB Bluetooth adapter

Read everything and still can’t resolve the problem.
My setup is:

  • Synology NAS DS920+ DSM 7
  • USB dongle ASUS BT500 (Bluetooth 5.0)

Running HA in VM (OS 7.4), CORE 2022.3.8. In the VM configuration, I selected the USB device.
Screen Shot 2022-04-16 at 02.55.01

This is my tracker configuration:

  - platform: bluetooth_tracker
    interval_seconds: 15
    consider_home: 180
      track_new_devices: true
    device_id: -1
  - platform: ping
    count: 2
    scan_interval: 30
    consider_home: 60
  - platform: ping
    count: 2
    scan_interval: 30
    consider_home: 60

But once I restart the HA, in the logs, I’m getting this error message:
Screen Shot 2022-04-16 at 02.58.04

How to connect the phone? Do I miss something?

I’m also using the HA companion application.

Thanks in advance

Maybe I’m going crazy, but I vaguely recall something about some USB device profiles not being supported on VMM in DSM 7. It all worked on DSM 6, though…

As in my first screenshot, the device is recognised and added to the VM machine. Found one post where people explain that the DSM 7 is rejecting the USB adapters, but VM is something else.
Also, as far as I found, people are still using some Zigbee adapters with DSM 7 and VM version of HA, so I feel that adapters are working if you are running HA with VM and not via docker. Maybe I’m wrong?

I think you are right… DSM7 change some rules

1 Like

I found this post below and because of that, I was thinking that the dongle can work. Maybe I was wrong? :frowning:

USB in a VM will work fine, because the drivers aren’t supplied by DSM but by the guest OS in the VM. USB is just passthrough for VM. Here I have it working perfectly: electricity metering P1, RTL-SDR stick and crelay. I migrated without problems!

Hmm, very strange, but somehow I found a solution. Maybe that’s not a fix, but after that, everything works.
I logged in to the SSH and ran the command

ha core check

After some checking, now my two android devices have been discovered. I can see the devices now in known_devices.yaml

1 Like

If u restart your nas are all your stick still there under “usb devide:” ? they dissapearing for me :frowning: do u also use conbee & zwave stick in WM ?

Is it possible to setup Bluetooth adapter with Docker instead of VM as well?

1 Like

@Tamiami unfortunately not yet, i was enforced to rollback to DSM 6 cause i don’t want to do some weird workarounds using VM’s. Currently you are able to enable USB drivers for some of devices like zigbee gateways, etc. But bluetooth is something different it is not single .ko file that you can load, because Synology did not published kernel sources for DSM 7 yet, it is impossible to setup bluetooth adapter. Since docker is something different than VM, system needs to load drivers for a device before docker will be able to use it.

1 Like

It is now

1 Like