[Solved] USB Bluetooth support on Synology DSM 7.1 and DSM 7.2

Hi man,
When you have time, can you compile kernel modules for apollolake?
Sorry but I’m not that skilled.
Thank you very much!

Compiled kernel bluetooth (bluetooth.ko and btusb.ko) modules for the following arch:

DSM 7.1
Linux 3.10.108 
x86_64 GNU/Linux synology_braswell_216+II


1 Like

Hey @nmajin @Globetrotter, any good news? Did you manage to make it work? I’ve also managed to compile drivers for my Synology NAS and initialize them. I see that hci0 device is available in container, but HA ignores it completely. I’ve actually tried two different adapters with the same results …

I did get it to work, but had to go into the home-assistant container and enable bluetooth there like you noted with hciconfig hci0 up. As mentioned, this is only passive, so I could not get say my Level Lock connected, tried to make it acive as well but wouldn’t find it. But I did find my plant sensor, so can confirm it worked for that.

By the way, I am messing with a Google Coral TPU now, and wondering if you could compile the driver for the PCIe Coral TPU if you have the setup still. I asked in this Issue here to see if it would be done as well: Google Coral TPU Driver · Issue #92 · robertklep/dsm7-usb-serial-drivers · GitHub

Here is how someone did it for unraid: [SUPPORT] blakeblackshear - Frigate - Docker Containers - Unraid

Sorry to switch up the subject but just curious if this would work and would save me the effort and time to compile myself if you are already setup for it.

Hey @nmajin

Thanks for confirming it. I had to do hciconfig hci0 up too and I also can only use it in passive mode.

Unfortunately I don’t have a setup for the arch that you have.

is any chance to compile modules for dsm 7.2? (4.4.302+ apollolake)
according to instruction, at location Synology Archive Download Site - Index of /download/ToolChain/Synology NAS GPL Source there are sources only for 7.1.1 and no for 7.2 (

I’ve compiled bluetooth modules for DSM 7.1, kernel 4.4.180+, apollolake (x86_64), DS918+, you can find them here:

I’ve tested that with my docker image that i’m using for presence monitoring, everything is working great.

Hey HighTower,

I managed to make it work on DSM 7.2 by following the instructions but taking the kernel source from https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.4.302.tar.xz instead of Synology’s website.

Now my problem is the same as many here ; I can see hci0 being up and working, but the home assistant integration I wanted (xiaomi BLE) says “No unconfigured Bluetooth adapters found”, my understanding from these discussions is that all integrations don’t work?

@HighTower, I’ve compiled modules for DSM 7.2, kernel 4.4.320, apollolake (x86_64), DS918+, you can find them here:

I’ve upgraded my NAS to 7.2 lately, i can confirm it is working fine, one thing that i did some time ago cause i had some issues with HASS it is that my container is running with network mode set to host.

Thank you very much!
I’ve tested and confirm that your modules works fine as for bluetooth as well as for serial!

Do you have the drivers for geminilake 7.2? Thank you.

Thanks for this. Are you able to share instructions on how to compile the modules or point me to links with resources on how to do it? Apart from bluetooth, I’m hoping I can also get my DVB-T USB tuners working.

I finally decided to upgrade to DSM 7.2 on my DS220+ geminilake, kernel version 4.4.302+.

Everything was smooth, I also compiled the bluetooth modules

I’ve also created a guide on how to compile them for DSM 7.2 if anyone needs to compiles for other architectures.

I used my DS220+ to compile, inside an ubuntu docker container.

1 Like

Hi guys… I managed to get my bluetooth adapters to show up in home assistant following this thread. However, it comes up as “Failed setup, will retry”… when I check the logs it says:

" * Config entry ‘00:19:86:00:0B:79’ for bluetooth integration not ready yet: hci0 (00:19:86:00:0B:79): Failed to start Bluetooth: [org.freedesktop.DBus.Error.ServiceUnknown] The name org.bluez was not provided by any .service files; Retrying in background"

Any ideas how to fix this?

amd v1000 drivers


To have hciconfig hci0 up on boot do the following


  hciconfigup: "hciconfig hci0 up"


- alias: hci_config_up
  description: "hci_config_up"
  mode: single
    - platform: homeassistant
      event: start
  condition: []
    - service: shell_command.hciconfigup
      data: {}
1 Like

Yeah, wanted to ask this too, same problem here. Let me know if you have any updates. Tried fixing this for the last hour, sadly no progress.

I used my DS1517+ to compile, inside an ubuntu docker container on DSM 7.1. I spent 2 days achieving this goal, but could not assemble the modules. Does anyone have AVOTON for DSM 7.2?

tried it myself, I am getting some compilation errors.

I suspect DSM 7.2 avoton doesn’t use kernel v4.4.302 but maybe v3.

Maybe someone with DSM 7.2 avoton can help with the kernel version (uname -a)

How did you guys install BlueZ?

I assume that’s why I’m getting this error “Failed to start Bluetooth: [org.freedesktop.DBus.Error.ServiceUnknown] The name org.bluez was not provided by any .service files” ?