Something is eating my disk space

Hey guys,

Since a week i’m running hassio and I noticed that my disk usage is growing every day.
Last friday I used less than 2GB. Today i’m using 4.56GB and every day it increase.

My home-assistant DB and log are together 109MB.
I have influxdb running which is logging ha & Glances.
I tried to find out how much size influxdb is using at the moment but without any good luck.
I found a some instructions, also on this community but they didnt work out for me.
Sometimes they give ssh instructions but when I follow this my ssh says that commands are not known.

Who can help me to find out what is eating my disk space.
Personally I prefer to setup an external ssd or usb stick to save all my logs and data.

So depending on your Linux skills, you can use
df -h
to find the space used on mounted devices
du -hs
Will give the a summary of the folder sizes for were you are in the folder structure.
I would start at the root of the drive i.e.
cd /
du -hs
Then cd into the biggest directory and repeat till the size jumps down, then
cd …
Will put up up one directory and you can
ls -h
To show you the file sizes

(The -h is for human readable i.e. mb GB etc, -s is for summary)

Thanks for your message. While I was looking for a solution I found a similair instructions as yours.
I deleted influxdb btw yesterday because it was broken for some reason, so my used capacity is now lower, but still growing.

When I do df -h this is my output:
image

When I do du -hs in my root it returns; 302.8M.
du -h in my root returns this:

So no big folders or files in my root?
Wrong device mounted?

I already checked last time all my folders, looking for logs for example.
Even I was looking for my influxdb directory, but couldnt find it.

My linux skills is very low, i’m just a hardware & program lover.

You’re running these commands in an SSH container. You’re not seeing the actual Host OS.

Perhaps you have old docker images that aren’t cleared out, but you should check backups to see if that’s what’s eating your space

I have no backups at all.

I already got some feeling I was not in my real root. Any possibilities to get OS SSH?
My disk usage is now 3.6GB. It is still growing even without influxdb.

https://developers.home-assistant.io/docs/en/hassio_debugging.html

Did this start around the same time you started logging Glances into Influx? That was the culprit on my system, solved by setting a short retention policy on the Glances DB inside Influx.

D’oh totally missed the hassio bit and forgot about containers
:tired_face:

I am having the same issue. It’s not a lack of basic linux skills but a lack of understanding how to access the sd card outside the ssh container. Appreciate any hint/advise. Couldn’t find any help in the forum yet.

I have got the same problem and it does not seems to be easy to solve

Same issue here. My hassio just stopped working as a result of the /dev/mmcblk0p2 consuming 29gb. I was able to clear up about 3gb for it to start working again.

21 hours later and now about half the drive space has been mysteriously cleared. I am not certain what did it but I think maybe a hassio upgrade has some cleanup scripts in them? Still baffled.

I had same issue with eating disk space:
Problem solved by comment logger part in /config/configuration.yaml

1 Like