Something is filling my hard drive

I have not found any additional information. It appears to be slowly increasing still. I’m sitting at 37.50 GB for the actual size.

My logs folder was 1.8 GB back in July. I just pulled it back up and its at 3.9 so maybe this is the culprit. I didn’t pay much attention to the actual size of the Hassio install originally so not sure how close I was to the 32GB virtual size before I upped it to 64 GB. I’ve just been monitoring it every couple weeks for any large increases.

I’m using a Rasp Pi 4B as well and noticed the space filling up on the SD card about a week or two back. It seems to coincide with an upgrade from HassOS 3.X to 4.13.

I took a look and found the systemd journal to be the likely culprit and am watching it now. When I do journalctl -f when logged into the ssh root@<ip> -p 22222 I see a flood of dnsmasq query logs.

I don’t see any easy knob to turn off dns query logging for the dnsmasq add-on though.

EDIT - 2020-09-28:
It seems like the usage has now leveled off around 20% and has stopped growing. I don’t know if that’s just normal log rotation or if me setting debug: false on my zwave: config section made a difference.

I’m wondering how to do this too. I’m looking through my /var/log/syslog file and it’s filled it DNS queries, often the same 5-10 within every second. Seems very dumb to be storing all of that activity, unless debugging. Is there some way to turn down the logging to WARN or something?

Problem solved by comment logger part in /config/configuration.yaml

1 Like


I have the same issue. I just noticed that my storage increase ~300Mb at a 2:00 every day… which is exactly when I’m backing my Home Assistant instance using GitHub - sabeechen/hassio-google-drive-backup: Automatically create and sync snapshots into Google Drive.

300Mb is exactly my backup size…

I’v checked my config and Home Assistant Google Drive Backup is configured to keep 14 backups in home assistant so disk space should not increase this way…

Anyone else noticed the same behavior ?

I have the same problem my disk is filled from June 10

I would suspect google drive backup. I’ve discovered that when GDB deletes a file on Google, it goes to trashon Google…but isn’t actually deleted for 30 days. I reached my GD limit, even though I had only 4 backups…the rest were in trash and I had to delete them manually.

On the HA side, I would check the log for Google drive backup and check to see what backups you have. Every time you update an integration it creates a backup…if you update three integrations, you’ll find 3 backups.

Poke around in that area…likely you’ll find your problem

I don’t have google drive so what’s problem :frowning:

If you have the supervisor/file editor addon, it will show you the sizes of all the folders. Which folder is growing so large?

I seem to have the same problem? (Or HA is maybe just grown as a OS?)
No backups and I did the:


Minimize home-assistant.log

max_entries: 500

So is 19G a normal installation?
I also moved my DB to external MariaDB

I have this same issue, my HA OS is reporting that my entire drive is full, even though I can’t find anything on the drive. I am wondering if HA OS just isn’t managing the disk space well and it thinks its full.

The culprit is usually either database, HA logs, system logs, or backups.

No backups, database is a couple gigs. When I run df from the cli, the overall HAOS files are small, while the NVME drive reports as being very full.

Check your system logs

I feel stupid asking this…where are they? When I get in the CLI via the add on or local monitor/keyboard HA is at most a couple of gigs. Running a df command shows that the NVME drive is almost full though.

I have the same issue on 32 GB space. Can’t find the cause. Did the same diagnostics. Gained some space by “ha su repair”. Occupancy from 90,3% to 81%.

1 Like

I connected to the drive and looked at the host files, I see a ton of what look like Docker images and containers. I made a backup of the system and wiped the drive. Now I’m down to about 5gbs of used space.

can u explain in more detail?
i followed spaceinvaderone:s guide on youtube and have hassio on VM on Unraid and experience problem with HA say disk is full when i have a 32gig vm drive and cant find anything taking that kind of space when i poke around.

I use an automated nightly backup. I was sitting at 97% full. Went to system>backup and selected all, then unchecked the backups from the last week. hit deleted all marked. went to 17% wow