Somfy URTSI II RS232

I just managed to get my Somfy rollershutter to work with Somfy URTSI II and Command line Rollershutter with raspberry pi and USB to RS232 adapter. This is one way control only, so rollershutter state is unknown. I’ll just leave this here for others to find.

- platform: command_line
    My Somfy Rollershutter 1:
      upcmd: echo '0101U' > /dev/ttyUSB0
      downcmd: echo '0101D' > /dev/ttyUSB0
      stopcmd: echo '0101S' > /dev/ttyUSB0

Hi @yada75,

Do you know some think for TaHoma devices?

hi @anarro,

I have no experience with TaHoma

Hello @yada75 , it’s 3 years later and I just so happen to have an URTSI II and am quite new to hassio. I’ve got my shades working with it manually, however I’m just trying to figure out how to send it commands via usb to RS232. Was hoping to copy your code almost exactly, but that rollershutter component no longer exists. I tried to use command line cover like this:

  - platform: command_line
        command_open: echo '0101U' > /dev/ttyUSB0
        command_close: echo '0101D' > /dev/ttyUSB0
        command_stop: echo '0101S' > /dev/ttyUSB0

but that did not work. I figured I would have had to set the baudrate to 9600 somewhere. Any help is greatly appreciated.

@hassface are you sure your usb is ttyUSBB0 ?

do some testing directly from terminal to verify, and you could try

dmesg | grep tty

mine says:

usb 1-1.4: FTDI USB Serial Device converter now attached to ttyUSB0

Could be called something else depending on hardware but should be listed in /dev/

Hey there @yada75 . That’s awesome that you were able to respond so soon. I actually just got things working, and I’m not quite sure why. Was able to do core-ssh:~# echo ‘0101U’ > /dev/ttyUSB0 from SSH and that worked just fine. After that I went back and pressed the cover switch I made in hassio, and they suddenly also worked after not working for hours. The only thing I changed from my code above was putting the full command lines in single quotes:

command_open: 'echo "0101U" > /dev/ttyUSB0'

Hi all,
This is good hint for my challenge: 8 relay board - RS232-USB controll - integration
Woudl any of you have any idea how to read the information from this device ?

Thanks, you put me on the right path here for adding the lines to manage the control
I had the same issue with Comm port settings, Added //Serial to set my port baudrate.

There’s other settings I might force just in case some other process decides to run a muck, but the baudrate got me set

# Set Serial Port Bauds
  - platform: serial
    serial_port: /dev/ttyUSB0
    baudrate: 9600

# Somfy URTSI II RS232 Integration
  - platform: command_line
        command_open: 'echo "0101U" > /dev/ttyUSB0'
        command_close: 'echo "0101D" > /dev/ttyUSB0'
        command_stop: 'echo "0101S" > /dev/ttyUSB0'

Just thought I’d share in case someone else stumbles here. I realize this is an old thread, but came in useful!


1 Like