"Sonoff iHost" (smart home hub/computer) from ITead - Can it be hacked to run Home Assistant OS with Bluetooth, Thread/Matter, and ZHA integrations?

Very interesting.

Could somebody explain how to create an SD card and boot linux in hardware initiated maskrom mode? Flashing the emmc image didn’t work for me.


1 Like
1 Like

boot.img.xz is the installer image that will flash the eMMC, but there is no indicator setup yet, so you really need to login to debug console to see what is going on.

1 Like

Are you using Windows or Linux?
Once you enabled developer mode/maskROM, the device will either show up as maskROM device or it will boot from SD card. Once things are sorted out, I’d be glad to help with a step-by-step tutorial.

1 Like

If you enable maskROM this way, you need to erase the eMMC flash ((using Rockchip’s RKDevTool or rkdeveloptool on linux) before it will boot from SD card.

1 Like

Latest images are on github now.

Very crude docs on the wiki page, hopefully some of the early testers can help fill those out a bit more!


You are fucking awesome dude! Thanks for your work! @darkxst

Hey Buddy, i‘d like to help and tried to install this Image https://github.com/darkxst/ha-operating-system/releases/download/v11.1rc1/haos_ihost-11.1.rc1.img.xz via etcher on an SD Card. After inserting the Card and sodering the two marked wires, its just flashing red since half an Hour. :sweat_smile:

Any Suggestions?

@Schreibi The indicator is not hooked up yet on the OS image. It will always flash red unless you manually send commands to it.

However provided ethernet is connected you should get the landing page after about 10mins (it takes a while as it has to download various containers) in the usual place → http://homeassistant.local:8123

If you power your iHost from your PC, you can connect to a debug console via USB serial connection, that will give you a shell on the iHost.


Thanks for reply @darkxst. I’ll try my best in the next few hours. I wish you all a wonderful weekend.

Thanks @darkxst, my HAOS is now up and running. One funny thing i encountered, i used a fixed ip address, assigned to my iHost earlier. This is why i was curious and thought the red light would indicate and error. I seems my MAC changed…and my router assigned this installation an new IP. Well long story short - it’s working fine with some minor issues. I am still struggling to get the zigbee controller implemented. I used EZSP /dev/ttyS4 (baudrate is 115200) . Overall process was quite easy. - Replace right side from Ihost Cover - soder those two above mentioned pins - flash image and you are literally good to go. To be fair, the red Led, made me think i made a mistake and the changed Mac Address wasn’t also that obvious but overall it was really not that hard. If i could get Zigbee up and running & that red Led indicator shut off, i would go quite far and say this is a far better alternative than Home Assistant Yellow or Green. Thank you very much for your time and effort to port this Image on this Device! Great work @darkxst

1 Like

The original MAC address gets blown away when you wipe the flash, but even if it wasnt no way to read it!. As we are using mainline kernel/u-boot, MAC address is generated from your cpuid and thus will be different than when you used the stock OS. Or in your case the flash is disabled, but still couldnt use if it wasnt!

ZHA seems to have troubles with the stock 6.7 firmware you need to update using ‘Silabs Flasher’ Addon with custom url. There are links on the Wiki page for 6.10.7 and 7.3.2 firmwares

Support for the indicator (and buttons) will be coming later. For now you can manually control it via the python script I linked previously. You can run this script in the Advanced SSH addon, but you need to add some python packages to the config:

You can probably use the init_commands to run the script when addon starts up after boot.


Good evening, great work, but I think I made a mistake. I followed a linux mode/maskROM tutorial and thought about installing homeassistant but I made a mistake and I don’t know how to do it, thank you.

The easiest way to get into MaskROM is to short the 2 pins mentioned in this post.

thank you I will try and let you know if everything works

because almost 1 year after 1st release, there’s still no backup/export/import solution for this thing… if it crashes, you’re lost, and forced to start over again…

There are plenty more benefits to running HAOS rather than HA Docker, some of the main ones being access to addons and direct access to ZIgbee (via ZHA or Z2M).


You contributed a lot to ihost users. I tried activating maskrom and installing HA as was done on Raspberry… but as you know, without success. when I was already thinking about throwing my ihost in the trash I saw your work and tested it (patiently) and it was perfect! Now I’m going to add other firmware like ZigBee and others…

Here is a library for the yc1175. This will form the basis of upcoming custom integration for Home Assistant, but in the meanwhile you can use this from within the Advanced SSH addon.

pip install yc1175-indicator
# main rgb indicator, blue flashing
indicator-cli 4 --effect 2 --rgb 0 0 255


I’m ready to try your project,
is there a way to restore ihost back to its original working
i also wonder where , is the installation of the home assistant on the built-in 8gb emmc memory or on the sd card?