"Sonoff iHost" (smart home hub/computer) from ITead - Can it be hacked to run Home Assistant OS with Bluetooth, Thread/Matter, and ZHA integrations?

In my opinion it has nothing to do with wifi5 or wifi6. Sonoff can only connect to 2.4Ghz wifi. In my case wifi has never worked probably even before I’ve started using HAOS (but no way to check it on ewelink firmware). So, wifi was not present in HAOS since always. After almost a year of using HAOS (via ethernet) it just stoped working during the night. It was still on guarantee and I’ve got replacement. It’s still in the box because ewelink firmware is useless and I don’t want to risk with current HAOS version. I hope this project is not dead and we can use ethernet and wifi on our devices soon. On the other hand I’m using another iHost in my parrents house. It is using HAOS with ethernet connection since about 5 months and everything is OK. Even wifi works as it should, because I’m checking it from time to time. Once again, I hope it is not the end of this almost perfect project.

In fact, it has nothing to do with wifi 5 and wifi 6, but I believe that routers with Wifi 6 technology have different ethernet port behavior as they have more processing capacity. But now I’m trustful with the usb-ethernet adapter! so much so that I’m thinking of a way to even change the faulty network chip on one of the ihosts I have to see what happens.:sweat_smile:

1 Like

Hi,
I tried to install HAOS on my iHost 4GB (fw 1.14.0) but without success.

  • I shorted the MaskRom pins.
  • Flashed haos_ihost-12.0.rc1.img.xz onto my SD using Balena Etcher.
  • Started iHost with the SD.

http://homeassistant.local:8123/ was reachable but remained on “preparing Home Assistant” for over an 90 minutes, after which I tried to restart but it remained stuck on the same screen.

I also tried installing on eMMC with the file boot.12.0.rc1.img.xz but it didn’t work. I left it running for over 30 minutes. The original firmware is still installed. At least the good news is that I didn’t brick the device =)

I’m doing something wrong?

Try to use ip address. You’ll find it on your router.

I’m curious if there is any progress with solving the ethernet connection problem.
I feel like without @darkxst support this forum is dying.

I’ve already tried with the IP, it doesn’t change anything.

The installation on SD card doesn’t complete, and the installation on eMMC fails (the stock operating system remains).

First of all check on your router if your HA gets IP address. If yes, then ip_number:8123. If not it means that you have to burn again sd card. Be sure that you’ve made this step correctly. Check if the mask rom pins are connected. Boot from sd card, it’ll take about 20 minutes. Then check ip address and write it wit port 8123

I assume you know there is different image for sd card and for internal memory. Use correct one

Not yet, I’ve tried everything I could think of, so far no luck.

Been a bit busy with other stuff, but will do another update release synced with upstream soon and try again to find a fix.

did you solder the maskrom pins, or just shorting them at boot. IF its the latter timing is important, short it for too long and the eMMC will be disabled on boot and the installer can’t work then.

hello! I’ve already installed this solution on 5 ihosts and when what you said happens I use rockchipdevtool to clean the flash. It usually works later.

It has also happened that the SD card is not formatted properly, especially if you use Windows OS. The card must be clean and without partitions when you record the haos image.

This tool can be troublesome in itself, however once you wipe eMMC flash, iHost will always boot from SD Card (without maskrom hack)

2 Likes

Thank you for all the responses,

I soldered two wires. The initial idea was to put a switch on the case to choose whether to boot from SD or eMMC, but the SD installation failed. I managed with the eMMC one. It was a timing issue. After a few attempts, I succeeded, thank you very much!

@darkxst FYI, ITead has now launched a new “Sonoff Zigbee Bridge Ultra” / model “ZBBridge-U” computer appliance hardware product for $60 US-dollars (or $51 US-dollars with coupon on sale until May 31st) that on paper looks like it might be a slimmed-down/cut-down version of the original “Sonoff iHost” variant with RV1109, as it is based Rockchip RV1109 (same as the RV1109 DDR4 2GB version of Sonoff iHost computer appliance hardware product), but this ZBBridge-U does not feature a microphone, SD card slot, or multiple RGB LEDs, (nor Bluetooth?), as well as having 1GB less system RAM memory.

SONOFF Zigbee Bridge Ultra (ZBBridge-U) specifications:

  • SoC – Rockchip RV1109 dual-core Arm Cortex-A7 @ 1.5 GHz with RISC-V MCU @ 400 MHz, 2D graphics engine, 1.2 TOPS NPU, 5MP H.264 and H.265 hardware video decoder and encoder
  • System Memory – 1GB DDR4
  • Storage – 8GB eMMC flash for the embedded OS
  • Connectivity
    • 10/100M Ethernet RJ45 port
    • 2.4GHz WiFi 4
    • Zigbee 3.0 via Silicon Labs EFR32MG21 radio SoC
  • Misc
    • Speaker
    • Button
      • Press and hold for 3 seconds: enters pairing mode (for up to 30 minutes)
      • Press and hold for 10 seconds: Factory Reset
      • Single press button: Exit pairing mode or cancel alarm
    • Tri-color LED
  • Power Supply – 5V/1A via USB Type-C port
  • Dimensions – 82 x 82 x 28 mm (PC+ABS plastic enclosure)
  • Weight – 92.5 grams
  • Temperature Range – -10 to +40°C
  • Humidity – 5% to 95% RH, non-condensing
  • Certifications – CE/FCC/ISED/RoHS
  • Safety Standard – EN 62368-1

Note! Spec are unclear if its USB Type-C port can only be used for power or if can use for debugging?

I spotted news about this on cnx-software blog which also listed the specifications copied in above:

Other than that I understand that ITead’s intended target audience for this out-of-the-box are Sonoff users who just want Zigbee to Matter Bridge for Sonoff and eWelink branded devices, as a way to proxy those devices into Matter-compatible gateways/hubs/controllers, such as those supporting the Amazon Alexa, Google Home, Apple Home, or SmartThings ecosystems. At least it does not sound like you can add Matter devices to the ZBBridge-U itself, so it only works as a bridge/proxy/converter/translator.

Similar description as the Matter Bridge function described on the Sonoff iHost product page:

Excellent news. Hope some results. Keep trying.

Yes I have seen this, likely it would boot fine with the existing HAOS images for 2GB iHost, but the lack of sdcard slot will make installing tricky. Also 8GB flash by itself is really not enough for HAOS. I suppose it could however run a small armbian build with ser2net for Zigbee gateway.

It will most likely work with rkdevtool.

1 Like