SONY BRAVIA KD43XE8077SU configuration

Hello, first post here!

I had a look through the forum for a solution to this problem but cannot find anything. I am struggling to configure my TV above with Home-Assistant. Here is what I tried (and what happened):

  1. added the “platform: braviatv” with the correct host IP; no bravia.conf file. Rebooted everything. The configuration module appears, enter 0000, a pin then appears on my TV, which I then enter in HA - the TV then says “configuration cancelled” and nothing else happens… note: I had removed all prior associated devices on the TV;
  2. as above but created a bravia.conf with the right host, pin, mac (quick question: the pin is the pre-shared pin? and the mac is the tv mac, right? that is what I have assumed anyway). Now two things happen after I reboot everything:
    2.1) if the TV is off whilst HA is rebooting: I see a Sony Bravia TV module and can see the on/off state, but none of the controls work;
    2.2) if the TV is on whilst HA is rebooting: I cannot see a module in HA and the TV presents me with a pin to enter every 30 seconds or so (the prompt only stays on for 10 seconds or so), I have no configuration modules etc…

In terms of config, everything is up to date etc…

Basically, I am stumped, don’t really know what else to try, so any help is appreciated!


I had the same issue. Basically, starting with no .conf file, you have to just keep trying until it works. Took about 5 consecutive “input cancelled” until it took it.

I am afraid persistence has not paid off, I must have tried about 20 times and still no luck, I still get “registration cancelled”

Logs indicate:
“ERROR (SyncWorker_4) [braviarc.braviarc] [W] HTTPError: 401 Client Error: Unauthorized for url:

I will subscribe the thread cause I have same error:

Oct 23 22:15:59 hassbian hass[4760]: #033[31m2017-10-23 22:15:59 ERROR (Thread-22) [braviarc.braviarc] [W] Exception: 401 Client Error: Unauthorized for url:[0m

My tv is a Sony KDL-43W808C.

Thanks all

I can add something…
I don’t know how :slight_smile:
…but my HA installation (hassbian) find the Sony TV with out configuration code in my configuration.yaml
I can select it and send a google voice … and it’s work.

Well, my configuration sees the TV or at least the Chromecast components t to the TV so I too can speak to it etc… However this is not the same as the braviarc module i.e. i cannot see channels, change them, not change the volume

I think that we make something wrong in the configuration of module.
Surelly the module is work… but is if there auth error, that mean that I make a wrong procedure, or my conf file it’s wrong.
So you are still in auth error ?

Yes, still in auth error

Nobody can help us please ?
Thanks again

Have a look here Denis, this solved it for me:

I have a similar problem on Sony KDL-55W905A:

hass[7851]: 2019-12-18 09:08:58 ERROR (SyncWorker_25) [braviarc.braviarc] [W] HTTPError: 401 Client Error: Unauthorized for url: http://tv6acfe2340cd2.home/sony/accessControl

The dialog box with PIN does not appear on TV. I would be happy to use braviatv_psk component, however my TV does not have pre-shared key option, namely there is no [Settings] → [Network] → [Home Network Setup] → [IP Control] → [Authentication] → [Normal and Pre-Shared Key] menu.

Any suggestion?