[still confused] Zigbee2mqtt - unable to pair new zigbee devices

Tags: #<Tag:0x00007f739ea5b1d0>

It has been a while. Think first I stopped Z2M docker-container, then HA. I removed all messages in Mosquitto MQTT-server related to buggy/faulty devices. I removed devices in Z2M, I removed devices and entities in HA .storage folder (core.device_registry and core.entity_registry). Then I searched for all ID’s related to buggy/faulty devices in home-assistant_v2.db. Start Z2M, reassign friendly_name, start Homeassistant. Done. Something like that.

Tried everything for a several days, all (exist) devices working perfect, no new devices can be paired at all.
Nothing helped, until I decided to REFLASH my dongle.
Everything started to work perfect (no need to repair exist devices)

Half the day spend desperately trying to get zigbee2mqtt w CC2531 working. Just before giving up on it connected the CC2531 via an USB extension cable. e voila it worked immediately. Before was jsut not able to get pair any other zigbee with it.