Strange behaviour of the supervisor

After a couple of years having a Raspberry pie running on the EBUS of my central heating I decided to go for the integration in HA and Node red.
After a couple of days learning about HA, I finally managed to get things configured and set up (steep learning curve)
Now I have setup a climate control on a generic_thermostat platform with a thermostat card in lovelace.
It works fine, but when I set the temperature, it changes back after a couple of minutes.
In the log I find this in the logfile “Living Room Setpointchanged to 14.0 by Supervisor”
What could that be?

the climate setup is simple

- platform: generic_thermostat
    name: living_room
    heater: switch.dummyheater_toggle
    target_sensor: sensor.nr_woonkamer_temp

I have changed to climate mqtt, but problem is the same

 - platform: mqtt
    name: living_room
      - "off"
      - "heat"
      - "auto"
    action_topic: "NR/Woonkamer/CVMode" 
    mode_command_topic: "thermostat/woonkamer/mode/set"
    mode_state_topic: "thermostat/woonkamer/mode/state"
    current_temperature_topic: "NR/Woonkamer/Temperature"
    temperature_command_topic: "thermostat/woonkamer/settemp"
    temp_step: 0.5
    precision: 0.5

I’m going to control everything in Node-red, but because of this strange behavior I removed all bindings with node-red (that didn’t change this behavior)

What’s going on here, and what can I do to keep “supervisor” fiddling with my thermostat?

Is it possible that this is the issue?

keep_alive time | integer (Optional)

Set a keep-alive interval. If set, the switch specified in the heater option will be triggered every time the interval elapses. Use with heaters and A/C units that shut off if they don’t receive a signal from their remote for a while. Use also with switches that might lose state. The keep-alive call is done with the current valid climate integration state (either on or off).

Thanks, it makes sense, but keep_alive time is not part of the mqtt climate control

But I retreive the temperature from the thermostat in the living room, it’s an ebus thermostat and the update rate is low.
I’ll make something in node-red so it will have a higher update rate, maybe that works better

That didn’t help, I send the temperature now every second, but still supervisor is setting it back.
“Living Room Setpoint changed to 14.0 by Supervisor”

If I check the Supervisor’s log, there is nothing that gives an error, there is even nothing in it telling it had to intervene

“Supervisor” is a bit misleading here. When a state-change takes place, Home Assistant is able to report the name of whatever was responsible for causing it (automation, script, user, etc). However if the source is external to Home Assistant then it can’t get its name (because it’s not an automation, script, user, etc) so it attributes it to “Supervisor”.

Node-Red is considered to be external to Home Assistant.

Thanks, that was indeed the issue.
I had a test flow running with another climate, I thought it didn’t touch the climate controller but it did and Supervisor was a bit misleading I was looking for something within HA itself.
Problem solved… thanks

1 Like

You’re welcome!

Please consider marking my post above with the Solution tag. It will automatically place a check-mark next to the topic’s title which signals to other users that this topic is resolved. This helps other users find answers to similar questions. For more information, refer to guideline 21 in the FAQ.