Home Assistant Community

Stream Component: Confirmed Cameras and Configurations

#34

Are wyze or blink cameras compatible with this?

1 Like
#35

Want to know too

#36

You may need to experiment with your cams, people may not have yours. If you find working config then post them here for others

1 Like
#37

Would love to see a HomeKit integration… :eyes:

2 Likes
#38

How can we use ffmpeg camera? E.g. for legacy cameras which don’t have HLS stream?

#39

same problem here… Why is still image a required field :frowning:

Reviewers needed: Environment Canada component with weather, sensor, and camera (radar) platforms
#40

ESCAM G02

- platform: generic
  still_image_url: "http://CAMERA_IP/snap.jpg?usr=USERNAME&pwd=PASSWORD"
  stream_source: "rtsp://USERNAME:[email protected]_IP:554/01"
  name: "ESCAM G02 Stream #1"
#41

FFMPEG is not yet supported, we tested this during beta and it was somewhat crashy. It’s being worked on.

2 Likes
#42

For UniFi cams on the UniFi NVR some additional info:
On a Raspberry Pi running HassOS you will have issues streaming the full 1920x1080 stream. Even the 1024x576 stream is at times too much for the Pi to handle. Currently the 640x360 stream works “best” but needs to be adjusted in the NVR so it has more than the default 200kbps bitrate.

I have tested the streams successfully using 500kbps bitrates, 15FPS and 360p on a Raspberry Pi. When you have more beefy hardware the higher res streams should be fine.

-Jan

Unifi Protect Camera Stream
#43

have not testd synology yet, you ?

#44

i threw a random jpg in and tested streaming it to my TV and it did work, but the jpg isnt the camera feed…

#45

The stream works fine for me for Dafang but there is alot of distortion now and then in the stream. What video settings do you Dafang user use have for your camera(s)?

#46

Vivotek Camera

I have the live stream_source working but not the still_image. Not even sure im doing it right to be honest :slight_smile: Anyway one question i do have, i dont hear the audio from the stream through lovelace front end. Is audio supported? the volume control is shown and i have turned up to max and tried mute button etc.

  • platform: generic
    still_image_url: http://192.168.5.76/live.sdp (also tried the mjpeg stream)
    stream_source: rtsp://192.168.5.76/live.sdp
    username: root
    password: xxxxxx
#47

Has anyone been able to get Foscam to work? I set up as a generic Cam and used the /videoMain path for the stream source, but I just get demux errors in my log when I try to play the stream. The actual camera tile works ok which I think is using the still image url.

Can’t post config at the moment but I do have the correct path for the rtsp feed (it plays ok in VLC).

Edit: nevermind seems to work in .90.1. Will post working config for everyone later today.

#48

Good, because I also have foscams attached to Synology, so I can use still image from foscams, and stream from Synology (if not smooth)

#49

Did someone make it work with ZoneMinder?

#50

I’m running on an i7 machine and don’t appear to be having any issues. Where do you adjust the default bitrate?

#51

anyone tried the RTSP stream coming from a synology surveillance system? its working for me, but the stream isnt fluent, when i click on the camera its a refresh every 2 secs

#52

That sounds like you are falling back to MJPEG, which we still do by default. Unless you see a media player with play/pause controls, it is not correctly configured. If you have stream_source set on the camera, you still need stream: set in your config to enable the component.

#53

ok, that can be the cause indeed
but, it i dont add stream: if i then click on camera, i see the live feed, but its slow
if i add stream: , if i click then on the camera, then i see the play/pause controls, but no feed at all anymore, just a black screen (90.0)