Stream component : unable to display rtsp stream

Thanks! now it works!

dafang is working but its too slow and laggy on my chromecast. do you experience the same?

This fixes the issue for me as well. I also use Unifi G3 cameras, but presumably it’s not isolated to the camera, more this javascript issue?

When I first added the camera it did work fine for a while, then one day I noticed that clicking on the card just opened a blank/black card that was stuck trying to load. Appending ?latest to the URL fixed it immediately (I’m on 91.1).

How to set it to display on my tv (Samsung TV).
Please guide

Problem with Dafang. Hassio gets real sluggish, even on a Intel NUC i7 with 32GB internal memory. Error in log file:

2019-04-08 08:51:51 ERROR (stream_worker) [libav.mp3float] Header missing

Look also at issue: Cant stream generic camera “Header Missing” #22591

1 Like

I have setup hikvision cameras and stream component.
I am able to “camera.play_strem” on a google screen cromecase device without issue
But on Hassio front end, after i click on the camera, my player always have a black screen and spinning circle. I do not get any errors in my log file (just “started stream message”)

I have verified the url’s with iSPi and streaming directly on cromecast through “camera.play_strem”

Why I can not see the stream with hassio?

    - platform: generic
      name: Front House
      http://xxx:[email protected]:80/PSIA/Streaming/channels/102/picture
      stream_source: rtsp://xxx:[email protected]:8554/Streaming/Unicast/channels/102

You’re my hero with this ?latest hack. I lost several hours with dozens of configs and it was enough to add that crap at the end of the url :wink:


  javascript_version: latest

1 Like

Thank you… that solved my problem . The player now correctly displays the strem

I was having heaps of issues with the new streaming options as well with also heaps of errors but it is now fixed. I cleared my the cookies on my browser of my Home Assistant URL and it streams perfectly. I have no idea why or how this has anything to do with it but it works.

This workaround works for my yoosee cam.

1 Like

would you please guide me to use rtsp for my hikvision NVR ?
I’m not able to stream on my home assistant

can you see the cameras in HA? as the problem you might have is, you are using the poe switch in the NVR? which then creates internal IP addresses. I use a separate pow switch so they are physically on my lan and get a static ip from my router.

The cameras in HA are showing “Idle” and there is no pictures.
All cameras are connected to NVR poe ports.


Here is my config for one of the cameras


There is usually a way to access each camera individually on an nvr… sometimes either changing the port number or the number of “channel”

1 Like

Thank’s a lot for the link … It seems that if I enable the Hik-connect in the NVR then the encryption is by default enabled and the RTSP streaming links will be nonfunctional

I already had the POE switch before I had the NVR, and decided it wasn’t worth the hassle to move to the NVR. Sorry I’m not able to help


Having also problems. Getting error:

2020-05-04 23:33:36 ERROR (stream_worker) [] Error demuxing stream: No dts in packet

My config:


Camera is a DCS-825L D-Link. rstp URL works fine in VLC…
So if I read this tread a lot of users are experiencing the same problem. Is there anyone who has this working with the same cam?
Also tried to use the ‘?latest’ solution but that didnot work…


btw HASS is fantastic! :slight_smile:

Testing stream again with my cameras tonight and I founded that now, with onvif cameras, you can specify the transport (upd, tcp etc).
But sadly, you cannot do that for Generic cameras in which you can specified an rtsp “udp only compatible” url :frowning:

So what’s the best setting to use stream in frontend/Google assistant?