Stuck on "custom element doesn't exist" - need help!

Nope, I have tried with monster-card as well as weather-card as the only resources in ui-lovelace.yaml. Same problem. I have tested bignumber-card too, and it works fine.

Same here. Checked permissons and owners of files.
The config/www folder is working on old frontend without lovelace…
Can’t use any custom component…

same here!

what browser do you use?
in chrome some of the modules are working in my configuration.

Mostly Vivaldi and Chrome. Also Firefox, but the Lovelace UI looks really ugly in FF.

i can‘t find the issue!
the only card that works correct is the gauge-card. the others give me errors: custom card doesn‘t exist…



I’ve tried the two card that are not working for you and they are working fine for me.

Have you copied also the animated gif described in Custom animated weather card for Lovelace ?

In this case I respected the folder as in the thread

In the moster-card case I used my folder as I told you in the other thread and it’s working fine as well.

Try to double check indentation.
There must be something missing…

Sounds to me like a browser issue since not all browsers support the custom element feature or latest javascript, which leads to some cards works and some dont.
Try an updated version of Chrome on your computer and when it works there you can move on to other browsers and devices and be sure that there is no config mistakes.

How about Chrome Version 69.0.3497.100 (Official version) (64 bits)? I am running Ubuntu 16.04 and upgrade it at least weekly, so I should be on the latest and greatest of the browsers.

I am just curious why HA seems to be so picky about java and browser versions etc. Seems as it is really on the “bleeding edge” of things as it is so sensitive to this.

Tryed a few browsers… FF, Chrome, IE and Edge… Not working.
I don’t think it’s a browser problem.

Hey Guys

set to auto instead of latest seems to work


  javascript_version: auto

Tested. Sadly not working for me…

Made it work guys!
I saved the files with “Safe link under…”
But this downloading not the .js file. It makes an HTML file but with right file endings…
Go to github, click on Raw, copy the code, open notepad ++,paste code, safe file, copy to ha, have fun!


Thanks, that figures. I have been downloading the wrong format I guess. I can see now when I replace the files that they are typically 2-5 kB in size instead of 80-100 kB!

I think many people like me are new to downloading “Raw”. I have been using Github for years and got used to find a green button to download a zip file for the whole project, including the js files or whatever files I wanted to download, which I think is the case with the custom cards that work for me. The other ones I have just downloaded by right clicking and “Save link as…”.

I will test it as soon as I get home!

By the way… It’s important to clean the ui-lovelace.yaml with all the old “wrong” files and their bindings.
Then restart HA service and insert again resources and bindings in the ui config file.

for me the issue exists in Chrome, but the same cards work fine in IE.

Try upgrading to version 0.81, it has fixed the issue for me

The problem for me turned out to be faulty .js files. After I made sure that these were downloaded and saved properly, it has worked for me in all browsers.

What was new to me was the “Raw” option on Github that I hadn’t discovered before. If you click to view a .js file, there are 3 buttons at the top right of the view. Clicking on “Raw” opens a plain text view of that file. Select all with Ctrl-A and copy it. Paste it into any text editor and save the file with the correct filename [filename.js] in the /config/www/ folder of HA. You should then have the correct .js file in place and referencing it with the correct path in the ui-lovelace.yaml should then work.

1 Like

For me the problem was a wrong word… :0)


  - url: /local/tracker-card.js?v=0.1.5
    type: js
  - url: /local/monster-card.js?v=0.2.3
    type: js

…and after

  - url: /local/tracker-card.js?v=0.1.5
    type: js
  - url: /local/monster-card.js?v=0.2.3
    type: js

Just wondering if anyone can help me with the same issue but I’m only experiencing it on an older iPad when using some custom cards, works fine on a newer ipad/laptop etc…

1 Like

@scottdarby - Same here, I’m running an old device with IOS9 and this error appears on that device only. I have tried mobile safari, mnobile chrome, and also the native IOS HA app. All other devices work fine, its just the IOS 9 device…did you get to the bottom of this?