Supervisor update

SUPERVISOR_MACHINE for Intel NUC should be generic-x86-64 or qemux86-64?

How come the “Snapshots” menu is already replaced with “Backups” in my two installations even though I have not updated anything? I’m running the OS version of HA. Also what is the version number of this new Supervisor, the blog post doesn’t mention this?

Supervisor updates itself, and the new one is 2021.08.1

1 Like

Thanks, must have missed this info until now. Any links to more info about automatically made changes to the installation and how to turn them off if necessary? Couldn’t find this on the docs or the UI.

You can’t turn it off.

Feel free to vote


Hi David

I am experiencing same issues on a raspberry pi 3.

  • upgrade to bullseye
  • installed os agent
  • rerun supervisor install script

It runs, but cpu through the roof and still remark that supervisor is not running on supported os

Is there anything to do with docker ?

It could be docker… did you update the sources.list for the bullseye docker repo and update?

Thanks david,

I have limited knowledge on docker and where to make these updates, can you give some pointers

I found this file /etc/apt/sources.list.d/docker.list
deb [arch=armhf] Index of linux/raspbian/ bullseye stable

Probably correct. Just check the
Install Docker Engine on Debian | Docker Docs
Just carefully follow those instructions (Including removing the old version)

Thanks David,
Tried the uninstall and re-install of docker on raspbian, but still get same result.
CPU usage has doubled since update to bullseye with frequent pieks to 85… so will go back to old install until these problems are resolved.
Enjoy the weekend !

1 Like

U2 mate. Someone else had CPU issues with Bullseye but updating docker fixed it. It’s funny because I have had issues with RAM and CPU but they seem fixed with 2021.9.2

Thanks for pointing that out, I was thinking too that it might be linked with latest update. Will give it a last try

That was it, upgrade to 2021.9.2 fixed the cpu issues.

Net issue to tackle the remark running unsupported os…

What does the Supervisor log say? Did you add the agent?

I wonder if it’s because it’s Raspbian?

I think it is the agent in combination with home assistant that creates the cpu issues and the wrong status

only armhf installation I have running, can’t say the cpu is over the top :


osagent is installed.

Hi Francis is that on a raspberry pi ?
I installed the arm 7 agent… maybe should try other agent

That is a Pi 2. I installed os-agent_1.1.1_linux_armv7.deb

Thanks that is also the one I used on a raspberry pi 3b, but unfortianetly not the same results as you have

But I notice you have the true debian install, I have the raspbian install