Support for Midea A/C

You said that your AC had both the 4pin and usb style plugs. Do you have one of these interface adapters for the USB?
image

Good evening everyone,

@vilord, my indoor unit became unresponsive when I plugged out the wifi board (even the IR remote didn’t do anything), the pinout of the 5 pin connector is different from the 4 pin connector. I’d say you’ll have a bigger chance of getting this to work with the board plugged in.

My AC does respond to commands from the ESP, however I dont get a response from the AC to Home Assistant. I also did not subscribe to the Telegram group yet, I Will do that when I have some spare time, I Just work to much at this moment :joy:

I’m using a Wemos D1 instead of an esp01, because that’s what I already have a bunch of.
Soldered it all up, it powers up just fine.
I was able to communicate through esphome to see the logs, but it is only transmitting, never getting any responses.
Can’t see or control the AC through the esp.
Hmmm.
This worked okay on the mitsubishis, but perhaps the uart in the AC is not willing to listen to 3.3v serial data. I’ll see if I have the supplies to level shift this up to 5v, and hope that’s the problem…

I just wanted to say to all of you a huge thank you! I just flashed a Wemos D1 Mini, and it’s working perfectly!

This is the config (if you’re interested in it):

esphome:
  name: d1_mini_03
  platform: ESP8266
  board: d1_mini

wifi:
  ssid: !secret wifi_name_1 
  password: !secret wifi_password_1
  manual_ip:
    gateway: !secret wifi_gateway
    subnet: !secret wifi_subnet
    static_ip: !secret wifi_ip_d1_mini_03
  ap:
    ssid: d1_mini_03
    password: !secret wifi_password_1

captive_portal:

logger:
  baud_rate: 0

api:
ota:

uart:
  rx_pin: RX
  tx_pin: TX
  baud_rate: 9600

midea_dongle:

climate:
  - platform: midea_ac
    name: "Midea AC"
    beeper: true
  
binary_sensor:
  - platform: status
    name: status_d1_mini_03
    id: status_d1_mini_03

For those who are using windows 10 and because the PR is still open, and you want to try it out:

docker build -t esphome:local -f ./docker/Dockerfile .
  • run the built docker image (just replace YOUR_CONFIG_PATH with the correct directory):
docker run -d --net=bridge -p 6052:6052 -p 6053:6053 --name=espHome -v YOUR_CONFIG_PATH:/config esphome:local

That’s it, and you can flash the ESP with a USB cable or with OTA.

2 Likes

I have made a test setup with a nodemcu esp8266. See if i could get this to work with my Mr. Cool minisplit. The wifi boards are identical as shown by nvschilleman

Unfortunately i did not have a 3.3/5.0v converter. I tried messing around with some resistor and such but not luck. I did however connect only the RX line and had the USBwifidongle from mr cool plugged in. And was able to read out the current settings every time something changed.

The TTL converter is ordered and should be here tmrw. Hopefully all will work and this will make alot of Mr. Cool owners happy! I am sure since there is no solution, and these units are very popular here in the US since they are sold as complete DIY ac minisplits.

Will provided update in next few days with some photos of the units.

1 Like

I can confirm it works with Mr. Cool units. Ill post some picture of the units tmrw.
This is really awesome thanks so much!

3 Likes

Thanks go all to:
:point_right: Mac-Zhou, Rene Klootwijk and Sergey Dudanov :point_left:

Here are some pictures of the Mr cool unit. Also my integration of the board.
Cut the blue board a little smaller then directly soldered the ESP01 on top. Soldered some wire directly to the green board. The usb connector is different then the norm as described by someone else.

Does anyone know if there is a way to turn the AC display on and off? I can do this with the infrared remote but was hoping i can do the same from esphome?



1 Like

As far as i know, not.
They have looked into it, but it seems this command is not available on uart, IR only

Following up on my post earlier, the 3.3v->5v level shift was all I needed. Plugged it in and a few seconds later the current temp popped up in home assistant, all working perfectly. Think I’ll reflash OTA to turn off the beeper. Thanks! This is with a Mr. Cool DIY 12k

2 Likes

@yodi

I was experiencing the same problem you have.
Following @aceindy 's advice I joined the Telegram group, thanks to the developers its working for me now!

Install ESPHome using custom repository dudanov:midea-climate-support-wo-integrity-check.
You can use the same yaml format.

I Just finished soldering 3 dongles, 2 to go! :grimacing:

2 Likes

Looks you can also atill use Dudanov’s main repository dudanov:midea-climate-support
image
The CRC check removal appears to be in both :stuck_out_tongue:

Thanks for following up @nvschilleman !

I tested the new version without the crc-checks and indeed now it looks like Im able to control my Midea, however if selecting Heat from power off state, the Midea wont start, but If I select Fan Only it start fine and im able to change to Heat once started. Is it the same also for you?

1 Like

A quick question: We have an MB-12N8D6-I AC. In the official app (Midea Air), we can measure the power in kWh. Is there any way to add this feature to the ESP Home?

I know that we have a power meter in the ESP Home, but the midea_dongle does not support them as far as I know.

Funny you ask…Sergey committed this 34 minutes ago to his midea-climate-support repository

Add this to yaml config

Power_usage:
    name: "Power"
1 Like

Hmm I do not have this problem, the only thing that does not work with my units is the Swing function. I’m fine with that since I dont use it. Maybe you could check your log and post it here when selecting the heat function from power off state.

@aceindy Oh I did not know that, might recompile one of my dongles tonight, I wanna see if my units also support power usage

Guys, a very long and scattered branch. Can you describe the complete algorithm for installing software on the ESP8266, please.
I have a Royal Clima AC, but inside everything is absolutely identical with Midea and the same dongles are used - OSK102, OSK103.
why ESP need TTL converter, we can connect RX and TX directly (https://www.esp8266.com/viewtopic.php?p=43862)

All info regarding the flashing of the ESP is in the first post (one of the main reasons to create this topic)
And you need the TTL converter, as the AC uses 5v and the ESP 3.3v
If you do not use it you risk damaging the AC circuitry.

Aceindy,

I still don’t understand how to add Midea AC support inside ESPHOME to HA

I don’t want to be rude or something, but maybe you should take some time to read the actual posts before asking questions that are answered by multiple posts in this thread.