Switchbot (meter) fail to connect / no unconfigured device found


I’ve just bought a switchbot meter (temperature and humidity sensor) that I would like to connect to HA via bluetooth (no hub), but I’m getting stunned.

If I follow instruction at here I am unable to connect the device to HA. I either get 2 message error:

  • ABORT: failed to connect to device
  • ABORT: no unconfigured device found

the switchbot are in range and I tried to start bluetooth pairing (long press back button) or not, since it is not describe in the instruction.

I am really bummed by this, I bought the device because I seen the integration and looked so simple, no hub required…

1 Like

Same here.
I can’t get the “Add Integration” work on my HA.
I bought a lot of Switchbot products this Black Friday and a NUC to setup HA, and I am very looking forward to set everything up with Switchbot stuff.
But I got the same error when I tried to integrate Switchbot device into the system.

I did some research on that on Google, there are multiple people have issue with the update 2021.10 version. The easiest fix for that is install 2021.09 version instead. However, the person didn’t leave any instruction, so I am still stuck.
There is somebody said that they will fix it on 2021.12 version.
So I will wait for 3 weeks so I can still return Switchbot product I bought.

1 Like

I’ve read that the meter devices are not supported by the integration :expressionless:

I’m looking into third party integration like sbm2mqtt

Same here.
I managed to connect but only get RSSI and battery
adding in configuration.yaml

  - platform: switchbot
    mac: 'a1:b2:c3:d4:e5:f6'
    name: 'myswitchbot'

(source Switch Bot - #5 by murtoz
Still don’t know how to get temperature and humidity. :frowning:

I have the same “No unconfigured devices found” problem before the intrgration is added.
I want to use it with the SwitchBot Contact Sensor, and that is set up in the app already. Anyne found a solution yet??