System won't start after update 2024.5.0

I’ve just updated my home assistant to the latest version through the interface.
As the server won’t show up, i’ve connected my RPI4 to a screen.
I can see the supervisor is starting.

If I wait a little bit I will get a message :slight_smile: Out of memomy: Killed process 5553 (python3) …

I have no idea how to solve my problem…

Is there a way to restore to previous home assistant version through supervisor command ?
I also have a backup on my google drive, but no idea how I can restore it…

I’ve run the command ‘ha res info’ and at the end I see:

  • context: core
    reference: null
    type: fata_error

Help will be very much appreciated !

ha core update --version 2024.4.4

1 Like

Ok thanks I’m trying

I have the same problem - I haven’t gone and hooked a monitor to the box yet, but it isn’t restarting after quite a few minutes. I’m on an x86 mini PC (bare metal).

Thanks Francis, reverting got the system up again. Odd though - that’s the first time I ever recall an update failing in years of use…

Update: After reverting, rebooting on 2024.4.4, and reapplying 2024.5 the same problem seems to be there - it booted into the GUI then crashed.

Using 2024.5 seems to be the issue… :slight_smile:

1 Like

The short version is that 2024.5 is faster and more likely to hit long-standing thread safety bugs in integrations. It’s slower and less likely to happen in older versions. If there are more bottlenecks in the event loop, a non-thread-safe operation that causes a crash is less likely to occur because there is less to conflict with. Previously, these issues would present as hard-to-track-down random crashes that rarely got fixed.

So, does that mean this is an expected outcome of speeding up the loading times, rather than a bug in 2024.5? If so, anyone experiencing this problem is left to rebuild their home assistant install from scratch and hope they are able to make it work like it did before, or they are stuck at 2024.4.4 forever…I’ve been through the logs and there isn’t anything that stands out, so it’s trial and error to fix.

It means that the integration with the thread safety bug needs to be fixed or disabled, as it is more likely to cause a problem than before. If you don’t know which integration is causing the problem, follow the instructions above.

Did you follow the instructions I posted above in 2024.5+: Tracking down instability issues caused by integrations ?

When I update to 2024.5 HASS won’t start, so I can’t use any features introduced in that version. When I enable debugpy in configuration.yaml it doesn’t produce any “RuntimeError: Non-thread-safe operation” errors under 2024.4.4.

Edit: I reinstalled 2024.5 with debugpy enabled. Also no errors. The system gets so far in loading and then just crashes…hard…the CLI stops responding, Samba stops working (I was opening the logs as text files since the GUI wasn’t working properly).

On 2024.4.4 and prior the system has been perfectly stable - no gremlins or random crashes.

Sounds like its a bad loop in an integration instead of a thread-safety problem.

Try starting up in safe mode and re-enabling custom integrations one by one until you hit the problem.

disabling “Dreame custom integration” solved the problem for me and several others.
Edit: It is possible to do that before that integration starts at the startup after hard reboot.

for info,
It was a success to go back to previous core version from HA supervisor.
And I have Dreame Vaccum Custom Integration installed.

I’ve tried this integration thinking I can start the vaccum through google assistant but it is not the case, so no problem to remove it !

Thanks for the quick and efficient help !

Same problem here. After updating to 2024.05.1, system will start but crash shortly after. 2024.05.0 was fine.
Had to revert to 2024.04 to get it running again. Upgrading to current 05.02 makes it crash again.

Any ideas?

There were many in the previous posts above including:

2024.5+: Tracking down instability issues caused by integrations.

Did you try any of those?

I just wanted to reiterate the problem may be with the most recent update. I tried refreshing my browser (i.e. chrome) but unable to reach HA via my Nabu Casa address either. If I recall I had a similar instance with an update and had to power down my RaspberryPi and back up again which fixed the problem (although I’m not comfortable doing this on a regular basis). Just thought the community should know. P.S. I do not have the Dreame Vac Integration installed.

I am having the same problem after updating to 2024.5.0. In my case it’s Zigbee2MQTT the responsible: Home Assistant crashes and reboots; then, after a few seconds (when Z2M starts), it crashes and reboots again.

I managed to quickly stop the addon shortly after one of the boots and deselect “Start on Boot”, but I don’t know what to do next.

I’ve tried updating Z2M (I was on 1.36.0-1 and updated to 1.37.0-1) but the problem persists.

@iway and @Emile31 how do you downgrade the HA Supervisor?

Thank you very much

Same problem (I think) and this situation is pretty messed up. The only nonstandard integration I have is frigate, so there’s no way an update should be so catastrophic. I can’t even load into safe mode, so I’m hoping I can even recover. What a disaster…