Systemair SAVECare Ventilation unit

This one?
image

Then it’s documented in the modbus manual. Don’t copy directly as this is from an old config.

  • platform: modbus

    slave: 1

    coils:
    • name: VSR Heater off
      slave: 1
      coil: 11203

Anyone know if something like this can be used as a wireless alternative?

https://www.aliexpress.com/item/1005005646573212.html?src=google&src=google&albch=shopping&acnt=897-548-8760&slnk=&plac=&mtctp=&albbt=Google_7_shopping&gclsrc=aw.ds&albagn=888888&ds_e_adid=&ds_e_matchtype=&ds_e_device=c&ds_e_network=x&ds_e_product_group_id=&ds_e_product_id=en1005005646573212&ds_e_product_merchant_id=109235179&ds_e_product_country=NO&ds_e_product_language=en&ds_e_product_channel=online&ds_e_product_store_id=&ds_url_v=2&albcp=19366796373&albag=&isSmbAutoCall=false&needSmbHouyi=false&gad_source=1&gclid=Cj0KCQiAnrOtBhDIARIsAFsSe53KEjPRqM27heMbMzzKJedOiePfSH2sjn5r0ww-SUsG1av79JhboRoaApKXEALw_wcB&aff_fcid=97f08b5e4b1243eeb5198f44d5bb114b-1705865555669-01285-UneMJZVf&aff_fsk=UneMJZVf&aff_platform=aaf&sk=UneMJZVf&aff_trace_key=97f08b5e4b1243eeb5198f44d5bb114b-1705865555669-01285-UneMJZVf&terminal_id=f98c9dd9fd6a4c5f997efc2e56d091be&afSmartRedirect=y

Wired connection would be hard for me.

That is it! And it is actually in manual I have, silly me I somehow missed it. In any case, thank you!

Hello there,
If any information on specific functions, features or implementation is required regarding the SAVE ventilation devices - I am here to help. I will also gladly share the non-public modbus registers for more complicated functionality.

4 Likes

Welcom Darius, very nice to see systemair participating here.

If you could send me the modbus specification that would be very nice

This looks awsome. Is there a way to use this with a Save Connect 2.0? I have a SystemAir save VTR250 and connected with a Save Connect 2.0, or do I need to buy a modbus over tcp/ip adapter, and if I do, can i make this work with the Save VTR 250 ?

edit: I see that the connect 2.0 can not be configured as modbus rtu to tcp. however the unit came with a “diverting plug”, so I guess its possible to go down the diy self route and connect some sort of modbus rtu>tcp adapter through the diverting plug.

However, I do see that if you connect to the connect 2.0 unit directly over http from a browser, instead of using the save connect app/cloud, you get more access then through the app/cloud, and it doesnt even ask for a password. One of the things abailable here is the possibility to read/write modbus registers. Unfortunatly I am not smart enough to program anything to use this, but it seems it would not be that hard to use this function to read and write to the modbus:

Hello. Found your great work, and tried to copy it into configuration.yaml as others stated it worked right out of the box……
I got the following error that i cannot resolve. (I am not very good at yaml at all)

I have read you now are on code red, but it seem a bit overwhelming for me….

Any help is much appreciated.

Best regards Lars

Check your indentation. It’s way off. Ang go through official docs to get it right.
https://www.home-assistant.io/integrations/modbus/
Some things have changed so the sensors goes to modbus section and you don’t need to specify the platform anymore.

image

Hello again, and sorry for all questions.
I have copied the code into configuration yaml, and when checking the file i get the following errors;

I have found the ip address to my saveconnect, but how do i find whitch port i should connect to?, and i also try to connect wia wifi, is that possible?

And lastly(for now) how do i see that i succed? Does it shop up under devices, or where do i find the screens?++

Thanks in advance for any help😀
Best regards Lars

The errors tell you all the lines you have messed up. Once again Check your indentation it’s very important for yaml. One extra space in line and your config is invalid.
Once successful you will get them under entities.
For wifi won’t help as i have a wired connection but maybe just run a port scan with nmap?

Thank you for your time, and answers. I have now been able get rid of all errors in home assistant, but have not been able to connect to the saveconnect hub. Found a program to do a port scan, but only port that showed up was 80. Did also try to reset the saveconnect hub to see if i could find a meny to select modbus as an option, but without success. So at the moment i just give up🥲

Best regards Lars

Hi,

It can be frustrating, if you find motivation at a later time, maybe the thread below can guide and help you out. As @moskovskiy82 write, check your modbus config against the official docs. If you are trying to use a modbus tool to check that the modbus communication is ok, you should most likely listen to port 502 (same port to be used in HA later), see the picture below, here i wirelessly check modbus data by reading modbus holdingregister 12102 (supplytemp). If you get data using modbus tool, it is your HA config you need to figure out. If you don’t read data using modbus tool, it is most likely the config in the gateway, or wrong setup in the Modbus tool.
Iv’e mostly used Modscan and Modbus poll, i believe both can be downloaded and used as trail version for 30 days or so. There is most likely much other software for testing modbus, which i’m not familiar with.

Good luck!
Br GM

https://www.domotics.no/post/home-assistant-automasjon-av-ventilasjonsanlegg-via-modbus?fbclid=IwZXh0bgNhZW0CMTEAAR1QH9_3lqwP8tTZ61IYfe4nG_BwPqDnW3tVsm0j9qC9eNEVt8UVcOKKMZ8_aem_Af-qn1ibgSvEARQmdsgH3bHJcAS3x2H8X6wEAi300otlEwSh13YZ-TT_N1coGUhnTqSEFAwieEJkHskK0zgP3nhB

Modscan test tool:

Do you have the SaveConnect IAM 1.0 or 2.0?
It is only IAM 1.0 that supports modbus, and you must activate Modbus from the web GUI (and therefor loose your access to their Cloud/app).

I guess thats where the problem is then, i have the iam 2.0.:sweat_smile:

Sorry :slight_smile:

If you go with an RS485 to WiFi or Ethernet then you can attach that one to the Modbus interface on your SystemAir SAVE VSR, and still keep your IAM for cloud/app.

I use Elfin-EW11a, you can buy that One from many places pretty cheap, and it works with HA.

@DariusSystemair, how about enabling Modbus on IAM 2.0? :grinning:

If you have the same IAM as me (not sure if i have the 2.0 or not, it doesn’t say. IAM HW version is empty…).
Have you enabled the modbus connection? (web interface, IAM login password is on the back of the gateway). Ref. pictures below.

IAM gateway settings, you have to choose either the cloud or modbus:

Modbus settings in the display, the slave adress must be the same in HA:

My IAM gateway:

I cannot find theese setting in my web interface….
It looks loike this on my;

So i guess i must have an unnsoported version😅

Best regards Lars

Did a search for elfin adapter in aliexpress. Seems to be different bundles an adapters available. How do you connect and power the adapter inside the vntilation? Or can it be connected to the save conneci iam?

Thanks in advance
Lara