Tailscale on android mobile to access home assistant does not work

I am new to HA and Tailscale. I added Tailscale in HA and later to my Android S22 phone. But than I can’t get remote access to HA. I got “connection failed”. When I wait I get the message “connection time out” … http://192 …:8123 … so, with the webadres I use for connecting HA on my PC.

When I look at “machines” at tailscale on my pc, i see home assistant end my phone as “connected”

May be somebody can help me!

How is HA installed?

How is TS installed?

Can you test from pc or try ping?

HA is installed on a mini PC.
TS is installed via the add-on “Tailscale”.
TS app is installed on my samsung android S22

When I Ping on my S22 the adress of Home Assistant 100.83… (see attachment) it works!

But when I start HA on my S22 the error “connection time out” displays the IP adres which I use on my PC to connect to HA.

So my idea is that HA on my S22 via 4G uses the wrong adress, but … I am new in this knowledge area :slight_smile:

If you’re using the HA companion app, there was a release this week to solve login issues.

Can you check if updating the app solves your problem?

I did the update, but does not solve my problem :frowning:

Try a browser on your mobile. If that still doesn’t connect, it’s not an issue with the app

Ok, but when I Ping on my S22 the adress of Home Assistant 100.83… it works! But when I start the HA app I get the failure, also when I type the address in the chrome browser on my S22.

Look at http: section of HA and trusted proxies. This could be issue.

Reading the addon docs it seems that HA should
Use https or you need setup for using http. In both case you need some config changes. Did you do that? It look like you specifically should not connect at HAip:8123 and I got impression that you were testiing this.

Under the DNS tab, is MagicDNS enabled? I believe it’s enabled by default but check if it is.

That feature makes your local network’s host names available on your tailnet. The host named homeassistant on your local network should continue to be found by the same name on your tailnet.

Double check that the HA app is configured to find your instance of Home Assistant by the machine’s host name, not the host’s IP address on your local network (192.168.xxx.xxx).

Yeah that seems right. Use the hostname, not the IP.

Ok, MagicDNS is enabled.

I can add the machine its host name at two locations in HA on my S22

  1. Companium App (see attachment):
  • and then Servers, server name “homeassistant”… same problem
  • Home assistant url … with the local IP or the TS machine IP … both do not work
  1. System/network
  • When I use the name “homeassistant” in the field “Home assistant URL” i get a error message.

So … what do I wrong???

According to the first screenshot you posted, the hostname of your machine is homeassistant.


In your second screenshot, see where it says Home Assistant URL?


Change its value from this:


to this:


This is great! Thnx a lot, its working :slight_smile:

You’re welcome!

Please consider marking my post above with the Solution tag. Only you, the author of this topic (or a moderator), can do that.

It will automatically place a check-mark next to the topic’s title which signals to other users that this topic has been resolved. This helps users find answers to similar questions.

For more information about the Solution tag, refer to guideline 21 in the FAQ.

This also fixed it for me! Thank you! Have been having the same issue as OP.

1 Like

Done!!! :slight_smile: