Tapo Hacs Camera integration

Hi, I bought a TAPO C200 camera and tried to install the HACS integration.
After about an Hour, It stopped working.
Tried to reinstall but it failed to even accept credentials.

Invalid authentication data. Make sure you have created your 3rd party account via Tapo app. You can also test if these credentials work via rtsp stream, for example VLC using link rtsp://username:password@IP Address:554/stream1I Text

I can’t understand because the VLC stream runs properly. the app works perfectly, I have a 3rd party account. also, I uninstalled and re installed everything both in the app and in HA.
I opened a ticket in Git Hub and was referred to the FAQ, but I cant find anything. useful.
I run HA in a mini PC with HAOS.
Any help would be usefull

Hi MrSilkworm

I assume you mean you have installed the Tapo-Camera Integration ?
Below is the url to this integrations “Project” Topic, where you can post questions related to this Integration

[Custom Component] Tapo: Cameras Control.

there is also links to the DOCS

Your C200 might only allow 1 connection, so you can’t access from both VLC and HA, at the same time, it’s either OR

For anyone to be able to help, you might also try to “structure” you question , stating what your do and where/when it fail, and if possible with relevant errors/connection entries from your logfile ( Setting/System/logs )

Also specify which Firmware & HW your Camera have
( As there is currently an ongoing issue in regards to some Versions , which is not “located” so far, and only some people seems to have problems, so far )

Scroll down to the bottom of the url i posted !, After you make sure you don’t have your cam “installed/exposed” elsewhere, before you try again ! :wink:

thank you for your feedback.
I’ll try to structure my reply as best as I can.

I have already studied the links you have posted before, without any changes to my problem.
All I can contribute further is that I already knew that there was a problem handling multiple streams, and I kept it simple to one stream.
Furthermore, I will add that even though the RTSP stream works with VLC, when I use other integrations such as a generic camera, for testing it still doesn’t work.
Therefore, by deduction, the problem is inside Home Assistant one way or the other.

Unfortunately, I’m not tech-savvy enough like you to pinpoint the problem further.
I have given some thought to dealing with YAML, but I have very painfully reached this point and I would rather unplug the camera instead of having to start from scratch.

So any additional helpful feedback would be appreciated.

Ok, have you tried the RSTP stream in the “Generic Camera” Integration in HA ?

PS: You don’t have to provideStill Image URL

I would try to reset the Cam, start with “Generic Camera” , if it dont work, reset the cam again and try Tapo-Camera-Controller Integration.

And when you post again “skip the talking”

  • Provide step by step what you done, and where it fails,
  • And Provide screenshots of your setting etc.
  • And also from your logfiles if there is anything relevant there /Settings/System/Logs

When you post codes like relevant snippets of i.e a logfile, please “Format” it properly so it’s readable.

You find howto in below, under PT.11
How to help us help you - or How to ask a good question.

I sincerely doubt that, i have 4st C200 And 2st C310 working fine in Tapo-Camera-Integration, they also worked in Generic.Camera
In Generic-Camera i have 3st D-Link Cameras running


PSA - Firmware 1.3.8 (or build 230921) and newer might cause integration not to work

There has been reports of users on firmwares 1.3.8, and newer, or on some cameras other firmwares with build 230921 and newer of integration stopping to work. If you wish to continue using this integration, until this issue is resolved, you will need to either:

  1. Block internet access of camera and stop using the app temporarily if you are using firmware 1.3.8 (or build 230921 and higher) and newer and the integration still works (solution not verified)
  2. Use older firmware than 1.3.8 (or build 230921) and factory reset camera (SHOULD work)

Learn more and discuss at #551 .