TCP commands for Ethernet relay

yeah, i saw it! indeed its better to create a new topic for new dobiss guys

maybe also mention that @spobo is creating a new component, so all this config is not needed anymore soon :slight_smile:

also maybe mention those 2 pdf files i shared , to make this project, i received them from dobiss

I used the dobiss specific thread to post an update to dobiss2mqtt. If it really works I’ll probably create a new thread for it. So check: Dobiss lights integration

Hi,

I’m new to Home Assistant and trying to find my way around.
I’m used to Domoticz but wanted to try something new so the logical choice was HA.

I created my own standalone home automation system that is based on a RS485 bus system with my own protocol (just 7 bytes) and has an Ethernet interface that accepts raw TCP packets.
I used Domoticz as an add-on to do some additional automation.
In Domoticz I used to run a Python script that sends the necessary bytes over to my system.

I’m looking to do the same from HA but can’t seem to get it going.
I’ve been reading and trying all kind of posts but still no joy.

The idea is basically the same as the one from Fabio but when running the python script I get an error that the import socket is not working. I read that python is kind of ‘sandboxed’ in HA.

Next to that I tried the curl option like:
echo -e “\xFE\xF5\xCA\x06\x03\x00\x3A” | nc 192.168.1.10 1500
Also did get it going.

I’m also a bit stuck in where to run what. What is the best way to test the curl command and same for the python script.
Tips and tricks are very welcome.

Thank you

Hi

you dont need an python script, you can just fire that with a command line switch/script


Thank you for the swift reply !

I also tried this before but think that my syntax might be wrong.
Could you please check if the given example is correct?

Example configuration.yaml entry

switch:

  • platform: command_line
    switches:
    zolder:
    command_on: echo -e “\xFE\xF5\xCA\x06\x03\x00\x3A” | nc 192.168.1.10 1500
    command_off: echo -e “\xFE\xF5\xCA\x06\x02\x00\x3A” | nc 192.168.1.10 1500

i think you need some extra quotes for your command

Could you tell me how you got the python script working as the curl or shell is not working for me unfortunately?
Then I can give it a try with the python script I used to work with.

Thank you

look at my post earlier, some examples there

or use this integration, sometimes easier
when you place those scripts on that folder, you can call the script with a service

Thank you for all the info and tips.
Will give it a try.

I tried to set this up but it’s not working correctly. It will go back to off after trying to turn it on, so the light will turn on indeed but HA things it’s off and it’s impossible to then actually turn it off :frowning:

Value template = false … To the rescue…

Then you can turn something on, while it’s already on… Or visa versa…

I’ll try at some point. I just somehow managed to kill the supervisor while playing with the switch code and I’m left unable to restart HA or any addons
:sob:

Started my own thread about dobiss2mqtt here: Dobiss2mqtt. If we know how something in dobiss works we can try and automate it via dobiss2mqtt so that adding dobiss to homeassistant is just adding a bit of config.

Hi, I’m also a dobiss user. I have an evolution pro system = ambiance pro + pro master. It includes lights, buttons, dimmers, outside sensor. I am pretty happy with it, however in meantime I have many other devices which aren’t able to connect to Dobiss (Philips hue, solar panels, climate temperature, …). I was really disappointed I wasn’t able to connect everything together. So using Home Assistant and combine everything looks brilliant! Will give it a try the next days … looks I am able to install it on a synlogy nas? Anyone of you has experience with it? Or is it better to install on a Raspberry Pi? My biggest concern was the integration of Dobiss, but it looks you guys are having solutions for that which is amazing. I am definitely not a programmer … but let’s see where we end. I see Rutger and Vincent are trying to make life easier, so definitely interested in those threads :slight_smile:

I dont like a PI, I am running HA on a esxi system…
Works perfect together with my evolution sx system… Really happy with it, although I am not using the dobiss2mqtt add-on, still using my own scripts

Hi Fabio, I will give HA a try on my synology nas.
Seems your scripts are indeed a total package :wink: also for me the actual status of the buttons is important as I also want to keep using my local hardware buttons. I’ve read this threads … many thanks for all your hard work on all of this.
I just hope, as I’m not a programmer, that I wil be able to do the integration within HA. However I do have a technical backgrond, so let’s give it a try :slight_smile: .
How many buttons do you have and how many relays modules? I have around 120 buttons and 7 relays modules. At the relay modules there are lights and roller shutters connected. I have 5 dimmers but it seems these are Niko dimmers and not the dobiss dimmers themself. And I have a light sensor connected which activates my outer lightning when it becomes dark.

i have 4 relays modules, with 12 input eachs, and 1 dim module, and also covers/screens
all my stuff is Niko as well, so i use the hardware buttons too to contol other stuff in HA
like turning on Spotify and some other Zigbee stuff as well
all my lights/switches/covers are exposed to Google Assistant too :slight_smile:
i have about 80 Niko buttons
but now i am adding Xiaomi movement sensors, in rooms where i forgot to place dobiss movement sensors, like in toilets, dressing … , works verry well

Has anyone got NetCat working on HASSIO?