The Future of Z-Wave in HA - QT-OpenZWave

Sorry, that’s what threw me off, the “LED Strip Effect” is an Int type :man_facepalming:

1 Like

I’m running HA in a esxi VM, and on a physical system I have in docker running OZW (openzwave/ozwdaemon:latest…and yes on the current build), and mqtt broker (eclipse-mosquitto). I have two battery operated devices that are always reporting as 100% battery left which I know can’t be right, especially since one just died and it said 100% the whole time. Even in OZW Admin it shows the battery as 100%. Prior to moving to the new configuration battery life was reported correctly.

The two battery operated devices are
Aeotech Door/Window Sensor 7 (wake up interval 86400)
Elexa (Dome) motion detector (wake up interval 43200)

I’m assuming this is an OZW issue.

To a point yes, but you can however enable refreshing on the devices by modifying the ozwcache XML file.

You’ll want to enable the RefreshOnWakeUp compatability flag on the battery status.


                        <CommandClass id="128" name="COMMAND_CLASS_BATTERY">
                                <Instance index="1" />
                                <Value type="byte" genre="user" instance="1" index="0" label="Battery Level" units="%" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="100">
                                        <Help>Current Battery Level</Help>

Is there any specific trick to this? I shut down my OZW docker, I made a backup of the ozwcache xml prior to making changes, made the changes, started the OZW docker and all of the changes were removed.

Sorry, try true all lower case.

1 Like

Looks like the setting has stuck. I’ll keep an eye on the battery levels. So far they all still say 100% even after forcing a wake up. I know one of them should be 100%. Can’t recall when I changed the other.

Just to make sure I am not missing something within my search, there is still currently no ozw event capture service set up? So I can stop having to keep track of these darned valueIDKeys

Are you refering to scene events? If so yes scene events are reported to HA as event ozw.scene_activated


    - platform: event
      event_type: ozw.scene_activated
        node_id: 38
        scene_id: 2
        scene_value_id: 1
1 Like

That exactly. I didnt see it in the beta OZW documentation page. This should save me tons of time after I re-work my automation flows. Thanks again

1 Like

Just making sure I have this correct, scene_id would refer to the index of the particular press seqeunce, such as “pressed 1 time, pressed 2 times, button held” events/actions, and scene_value_id would refer to the actual scene index, i.e. which scene button is pressed?

Depends on the device, they should be nearly identical to your old automations.

I was using mqtt listen nodes within node red to manually listen to button press events for all my switches, so this will be a bit different.
I just tested this idea with internal text automations and it works perfectly. No more unwieldy node red flows for simple on/off commands.
I need to buy you a couple beers man, cheers!

1 Like

I have 150 running also turned on the polling for the dimmer I’m screwing with using your instructions on how to send it via MQTT.

I can get the dimmer on, it takes flipping the switch 2x though and won’t work in an automation. If if flip the switch a few seconds later 10-20 it updates and is correct, I assume because it gets polled.

Any other ideas how to get the dimmer working?

I just tried another z-wave dimmer that I have and it works just fine (couldn’t earlier because someone was working in the room that it is in). I guess maybe it has to do with the manufacturer of the dimmer?

Did adding it to the new plugin reset your dimmer settings? And the setting for the button changed from on-off to momentary? Wild guess…

Correct some dimmers have instant status, some do not.

You’ll have to wait till there’s an update from the ozw end of things.

Cool. thanks for your help. Much better than beating my head against the wall.


Since last week i started using this new integration (openzwave).
After a restart of home assistant core i receive this error inside the log:
Sensor not implemented for value Error Code

How can i solve this?

Hello, I have regular unresponsiveness. No errors, just not doing anything. Reboot container (addon) and gone… sometimes 1 month, sometimes 2 weeks. Any suggestions?

Just wanted to point out, someone wrote a script for the LED strip for Inovelli dimmers and switches here as well.


Also, if you use Node Red, there’s a node for it that you just feed into an ozw.set_config_parameter. I have not tried this yet since I moved from Z wave to OZW, but it should work. Guessing the LED setting will still fail until .115 comes out, but notifications should work.