The Haaska Super Thread

haaska
Tags: #<Tag:0x00007fd077546830>

#21

It is true that using HA Cloud, you don’t have to have a port open for Alexa. With HA Cloud, Home Assistant reaches out to a server (run by Nabu Casa), and keeps a connection open that way for requests.

On the other side, if you want to access your Home Assistant install while away from home (either web or mobile app), you need to have a port open, so you’re back at the same spot anyway. If you already have it open, you can set up Haaska with just a few changes.


#22

Cool, finally succumbing to the auth bullying so might as well do it now.

Many thanks as always.


#23

At the same time I transitioned to HA cloud is the same time, and for the same reason, I went to accessing my HA thru a VPN administered by my router.

I understand that I still need a port open but it’s a random high numbered port (not easy to guess what it is) that is completely (as possible…) protected by an encrypted key and username/password. And now that HA itself uses a username/password combination I feel my set up is about as safe as anyone could hope for outside of a corporate level environment.

If someone wants to get thru all of that just to turn on & off some lights then they seriously need to re-think their path in life. :laughing:

Don’t get me wrong, while I was using it I was (and still am) thankful for the work put into it and it worked really, really good. And maybe at some point I may go back if I think it’s necessary.


#24

I hope there will be an update in the wiki soon! Looking forward to integrate alexa a little bit


#25

As @anthonylavado said, you can use the guide here rather than wait…

http://collingwood.me.uk/blog/index.php/hass-io-and-alexa/


#26

Yes, things have been slow for me to update the rest of the wiki, as I’ve been super occupied with work, and now am helping maintain another project that has completely taken off on the charts.

I’ve got a couple hours free now, so hopefully I can finish this up. Haaska is pretty low maintenance once you’ve got it set up, and once I’ve got the wiki finished, it should be the same way.


#27

hey mate thanks for this I have set up haaska.

I was wondering how can I set up alexa skills custom ->intents? I had it setup before with https as the endpoint and my ha api password. However I was wondering how I could set it up using long lived tokens?

Or do I link in to my AWS Lambda ARN that I created i.e. haaska as the endpoint for my intents?

Thanks.


#28

@bachoo786 - Hey there! I’ve never used the Intents feature before, so I’m not sure how it works. I do know that it is different from what Haaska does, and they are not the same.

I tried to look quickly, and it doesn’t seem that they’ve changed the Intents code since January 2018, so I don’t think it can use a token. It might be a good idea to send in a feature request to Home Assistant!


#29

ah right !

I have a few intents setup using the api password, however they dont work now as I dont use HA api. When I was using your guide to setup haaska, I tried to use the endpoint of my intents to point to the one I used for haaska and it gave me an error.

Obviously I cannot use the https method as I dont use api password anymore.


#30

Is there a way to call Alexa routines from HA using Haaska? I would like to hear my flash briefing (local news in Finnish) when my motion sensor detects movement in the morning or maybe when I come home and open the front door.


#31

I followed the instructions and was able to successfully test the installation as described in the “Testing Haaska” wiki page. However, when I open the Alexa app I do not see the skill. Which got me thinking, how does Alexia know to associate the skill with my Amazon (retail) login? Does the login in amazondeveloper have to match the login I used to log into the Alexa app?


#32

Thats more of a alexa control thing than a haaska thing. Check this out

it does have the ability to trigger a routine on an echo. Does not even require haaska or the cloud component.


#33

@stu247 I hadn’t thought about this before. I just checked, and yes, you do have to use the same e-mail. Good catch!

See here: https://developer.amazon.com/docs/devconsole/test-your-skill.html#h2_register

Once you’ve got it linked up, it’s in the app, they just really hide it.

In my Alexa app (iOS) this is what I do:

  • Open left menu
  • Choose “Skills & Games”
  • Select “Your Skills” in the top menu
  • Slide “Enabled” over until you get to “Dev”
  • The skill should be there, and you can activate it.

#34

Thanks, when I switched Alexa over to the amazondeveloper login, it worked. The instructions said to do it on the web, but there was no option. I did it from the iOS app by first logging out and then in with the other email address.


#35

I actually know the answer to this. There’s two parts.

First, the reason you can’t install the skill on her account:

So… you custom skills can only be installed on your account unless you publish it. It’s unlikely that you will be able to publish…

Second, the reason she can’t use the skill:

Alexa can recognize voices when you train it. It can also have two accounts logged in at the same time. Next time it doesn’t work have her ask Alexa what account it’s in. If it’s in her account have her tell Alexa to change to your account and then she will be able to access all the device you can. It’s a bit annoying when you both have your own music service but, that’s how it currently works.


#36

Any news about this section in the wiki?


#37

Sorry I haven’t finished it. Any questions I can help with?


#38

I got it to work . After trying mix and match with 4 guides (was 6 months ago)
But my friend wanted to make it work. And I asked for him.

Looking forward for upcoming updates in the wiki


#39

I’ve spent several hours trying setting up haaska but unfortunately did not succeed.
I followed the instructions from the blog from The Wanderer, but the same error is always thrown by the Echo Dot v3"I couldn’t find any smart home devices" after discovery by “Alexa, discover my devices”.

Testing in Lambda appears successful: “[DEBUG] 2018-12-24T21:36:03.256Z e9374049-07c3-11e9-8834-edeaf19d5030 https://home.my.domain.com:443 “POST /api/alexa/smart_home HTTP/1.1” 200 None”

Also I’ve got the skill enabled in the app.

The strange thing is, when I test in Lambda I can see an entry in the Home Assistant logbook: “Amazon Alexa send command Alexa.Discovery/Discover.”

However I cannot find any logs in CloudWatch. I’ve rechecked settings several times, tried changing Lambda regions from Ireland to N.Virginia, changed address settings in developer account to US, switched from UK English to US English and back again, disabled and re-enabled the skill the app in but no luck :frowning:

Any help would be greatly appreciated!


#40

+1 - exact same issue here. Haaska was working previously, stopped and I have recreated it using all guides I can find. Lambda discovers each of my devices, I can link the skill - no issues up until device discovery when Alexa finds nothing. Any ideas?

As an aside - I am based in Ireland; I have set up all of accounts needed for haaska in UK to be as close to to the guide as possible. Tried Ireland, no luck.

Happy holidays everyone!