Thermostat won't stop heating (Tuya TS0601)

Hi; same for me. Still no luck.

there is a grey ring inside the thermostat mount. If that one is removed before installation, everything works fine for me.

(the image does not show the actual thermostat in question, I know. I made it just to show where the ring is)

will check it, there are 2 problems:

  1. water flowing even if there is 0% - force mode or ring removal needed
  2. even if the room has 22°, and set temperature is 21°, it opens to 25%. i disabled the setting according to PDF, nothing changed. looks like it is internal PID to maintain the temperature but in reality, it overheats the room

Is that little grey ring still installed in your setup? It looks like this when it comes out of the box:

I always take that ring out, then it works as expected after adapting to the valve.

1 Like

I’m having a similar issue, definitely no plastic ring, but i’m thinking the self-stop/calibration isn’t working very well with these valves, not sure if that’s something we can change.
Taking the TRV off and manually changing temperature, feeling the pin move it doesn’t take much force to make it stop moving down (to close the valve) so I’m thinking the force-feedback on it isn’t allowing my valve on the radiator to close (using a coin I can push the valve down, it’s not easy but I can, so definitely not stuck).

update: had also to disable window open detection

original post:
I have TS0601 TZE200.ckud7u2l and it was just heating except when manuall turning “off”. No other setting was taken into account.
I fixed it somehow. What I did, according to the post#5 above but a bit different.
Setting A was reset for me, showing 88. I did set it to 00 and another try to 08.
The setting where I was able to choose a 0 or 1 was setting 9. I changed it there to 1.
There was also an other binary setting with a lower number, 2, 3, 4 or something. I also set that to 1.
After that it does use my confort, eco settings. It does take some time to start tho (1min or so).

no plastic ring on mine.
i am fed up with this. i also tried another solution, and that is, to use Tuya TRVs as thermostats only(they can control the central heating pump switch), in each room, and temperature was controlled with good old analog honeywell TRV. not good, even if the whole house is heated and analog TRVs close , Tuyas command the pump to spin hot water and it overheats my bathroom, where there is no TRV. Pellet consumption is insane. will throw the tuyas out of window. and use normal thermostat again. originally, i wanted to solve just one problem: one room was colder all the time, and since the thermostat was in the warmer room, it did not trigger the heating pump.

since one week I am operating two of those TRVs at the moment - they close fine, but the internal PID is pretty “stupid” (trying to heat at 25% for two hours before realizing that the radiators and the room dont get warm at this position - as there is no water flow)

Does anyone of you know if you set

A “Control type of valve” to 1 ON/OFF

is the TRV still operating with steps (e.g. 25%, 50% …) or from then on it´s only ON/OFF, meaning 0% and 100% and nothing in between?

With BT my TS0601 valves will not close after reaching the target temp.
I tried different settings and for a short while they work as accepted, but than they not close the valves. Curiously, the heating icon from “better thermostat ui card” is grayed and shows no action then.