Time out waiting for hardware cmd interrupt Deb 11

I have followed the directions for home assistant supervised on Debian 11 at Installing Home Assistant Supervised on Debian 11 but no joy. I can’t get past section one, when I try to boot I get the following error “time out waiting for hardware cmd interrupt”. This is a pretty simple set of instructions and I have tried over and over and still get the same error. It is obvious that I am missing something here but for the life of me I can’t see it. This install is on a raspberry pi 4 with an m.2 ssd. I have verified I have the latest firmware for the pi, I have been able to boot other distro’s (ubuntu, rasbien ) etc. without problems just not this distro, any help or suggestions to try will be appreciated

Do you have a UART enabled in /boot/config.txt (enable_uart=1)?

Don’t know basically the instructions say to download the compressed image flash it and boot. Seemed simply enough lol but not for me I guess. I will flash the image to a sd card and see if I can find the boot config text and go from there. I appreciate you taking the time to help me,

The instructions on

are correct, but they don’t tell you you need to update your rbpi4 eeprom to be able to boot from SSD.

Maybe read here first :

Thanks, will give this a try. Again, appreciate the help.

After I replied I had another thought. I am able to boot from the m.2 now with other distro’s, ie when I install ubuntu or raspberry pi OS etc I have no problems booting in the os it is only with Debian that I have this problem. I will verify per the guide you pointed me to that I have properly setup ssd boot, but I wonder if that is the problem.

Maybe this can help :


After running sudo rpi-eeprom-update I get the following

~# sudo rpi-eeprom-update
BCM2711 detected
Dedicated VL805 EEPROM detected
BOOTLOADER: up-to-date
CURRENT: Thu Apr 29 04:11:25 PM UTC 2021 (1619712685)
LATEST: Thu Sep 3 12:11:43 PM UTC 2020 (1599135103)
FW DIR: /lib/firmware/raspberrypi/bootloader/default
VL805: up-to-date
CURRENT: 000138a1
LATEST: 000138a1

So it seems all is good on this front Right now I have home assistant install on Ubuntu with no boot problems.

Problem solved for those having the same problem the simple fix is to put a blank (erased) ssd card in the pi and continue on. Apparently the boot process using the latest raspberry eeprom (July 2021) I believe, first looks for an ssd card then a usb drive. So without an ssd card it reports "time out waiting for hardware cmd interrupt. After reading a lot of posts stating to change the boot config to this or that, I thought that since all of theses were trying to get past the no sd card what would happen if you just placed a blank sd card and try booting. It worked, I finished the home assistant install (not without other problems along the way) and now have a working system.

1 Like