Time_pattern trigger does not allow more than 59-minute interval

0-59 and 0-23

there is no 60th minute and there is no 24th hour
I’m pretty sure it does say that , i’ll go check …


Well not explicitly but it does say : -

With the time pattern trigger, you can match if the hour, minute or second of the current time matches a specific value. You can prefix the value with a / to match whenever the value is divisible by that number. You can specify * to match any value (when using the web interface this is required, the fields cannot be left empty).

i.e. which bit of the current hour, minute or second are trying to match with 123 etc. ???

The thing that is a bit annoying is the cryptic clue given in the ERROR doesn’t point to the line in the automation.yaml where the error “/60” is. Also, the “Check Home Assistant configuration” add-on doesn’t detect the error “/60”. Given this is a BREAKING CHANGE in 115.0 why couldn’t a WARNING be highlighted in the “Check Home Assistant configuration” add-on log?
Sure it was in the Breaking Change but I missed it.

That add-on checks the config against the future version of HA. However, I have already opened an issue over the fact that the config checkers don’t spot this. I’m ignoring the person there who suggested that because the UI editor throws a warning it’s not a problem :wink:

Hi, before of the update to 0.115 my automation worked with trigger time pattern. Now no more.
My trigger:
hours: ‘21’
minutes: ‘/20’

should work fine. Can you post the whole code instead of the 2 lines? Also make sure to format it.

It seems that hours, minutes, seconds should no longer be strings (at least if they are, then it doesn’t work anymore for me and others). There is this related issue: https://github.com/home-assistant/frontend/issues/7087

I implemented a POC PR in the frontend that converts the values to integers before saving them to YAML.

Before it worked, without changing anything now no. The format is correct unless with update changed something.

Well, we have no idea what you updated from and you won’t post the syntax. :man_shrugging: Not sure how you expect us to help.

1 Like

Oh, that is unintended fallout from PR#38982. I will fix that.

Related GitHub issue: Time_pattern automation triggers only reading the first digit. · Issue #40365 · home-assistant/core · GitHub