Token Error when using API commands from Configurator offical addon


From this morning I am getting a strange “token validation” error when I try to use API commands from the Configurator interface. I am using image with the official Configurator addon from the repository. I have tried to restore the last snapshot from Friday (before the issue) but I still get this error.

From the configurator git page I see that it must have an API password configured to call home assistant services but if I understand correctly the official addon from does not need to configure the api secret.

18-05-06 08:21:23 INFO (MainThread) [hassio.api.proxy] /homeassistant/api/services access from core_configurator 18-05-06 08:21:23 ERROR (MainThread) [aiohttp.server] Error handling request Traceback (most recent call last): File "/usr/lib/python3.6/site-packages/aiohttp/", line 381, in start resp = await self._request_handler(request) File "/usr/lib/python3.6/site-packages/aiohttp/", line 322, in _handle resp = await handler(request) File "/usr/lib/python3.6/site-packages/aiohttp/", line 88, in impl return await handler(request) File "/usr/lib/python3.6/site-packages/hassio/api/", line 36, in token_validation return await handler(request) File "/usr/lib/python3.6/site-packages/hassio/api/", line 108, in api client = await self._api_client(request, path) File "/usr/lib/python3.6/site-packages/hassio/api/", line 37, in _api_client method = getattr(self._websession_ssl, request.method.lower()) File "/usr/lib/python3.6/site-packages/hassio/", line 269, in __getattr__ raise AttributeError() AttributeError

Issue seems to be fixed now in Supervisor 103.2.

To upgrade:

1 Like


Thank you

1 Like