Trouble discovering Legrand with Netatmo switches in ZHA

Hi there :wave:
I have trouble discovering my Legrand wall switches in ZHA.
Here’s my setup:

I already have a functional Zigbee mesh with multiple bulbs and switches from IKEA or Philips Hue.

I put ZHA in discover mode and press the « down » button on my switch and:

  • nothing happens on ZHA
  • the switch blinks green twice, red once and then turns off

I tried removing the white cover to find the reset button but it does nothing more when I press it briefly.

When I long press the reset button, it blinks green twice + red once at the beginning, and after ~8 seconds it blinks red. When I remove my finger, it blinks again green twice and red once.

Nothing seems to turn it in discovery mode.

I read people on some forums successfully using these switches without Legrand’s bridge so I guess that it’s possible. Maybe something in my setup isn’t compatible? Maybe I’m doing something wrong?

I couldn’t find any documentation on Legrand’s website on what LED signals could mean. The battery seemed a little weak (just over 3.02V), I tried to change it for a full 3.2 battery but it didn’t change anything.

If somebody has any idea, I’m willing to try!

1 Like

I believe managing to put the devices in pairing mode would help a lot, if anybody knows how to do that or has links to documentation.

I have a similar problem with the pairing (2 green 1 red light) after reset.
I search but nothing found.
If you fixed the problem please inform us the moves that you do.

It’s not fixed yet unfortunately, but we’re discussing the issue on GitHub. I’ll keep this thread updated when we have something interesting to share.

My Conbee II was on channel 25 while Legrand devices seem to only operate on channel 11.

In order to change it, for the Conbee II:

  1. Install the deCONZ app on the device connected to the Conbee II (in my case: my raspberry Pi)
  2. Launch the deCONZ app
    a. If you’re running a headless version of the operating system (one without GUI), you’ll need to SSH with X forwarding enabled and launch the app from the SSH session. This should open the GUI on the device you’re using to connect to the RPi.
  3. From there, launch the Phoscon web app
  4. Change the channel in the settings
  5. Quit the apps

The deCONZ app takes precedence over Home Assistant and takes control of the key. While it’s running, you won’t be able to control your Zigbee devices on HA. It releases its control once you close it though.

After changing the Zigbee channel, you can discover the Legrand wireless switches in HA.

In order to successfully pair them, I had to:

  1. Start the discovery process
  2. Press and release the reset button on the device. If it only blinks green twice and red once, you’ll need to press the reset button longer until you see a red blink. Now you can release it.
  3. The switch LED will blink green multiple times
  4. Regularly press the bottom button to keep the switch awake (not sure if necessary)
  5. The switch will appear in HA and the LED will blink red once. At this stage, the device is not fully paired.
  6. Wait a minute (really, wait some time)
  7. Start the discovery process again in ZHA
  8. Press the reset button once and release it
  9. The switch LED will blink green multiple times
  10. Regularly press the bottom button to keep the switch awake (not sure if necessary)
  11. The switch will appear in HA and the LED will blink purple once.

Your wireless switch is fully paired and operational. It sends events when you press the buttons. It also detects long presses and sends an event at the beginning and another when you release it.

I’ve successfully paired 6 single wireless wall switches (600083), 2 double wall wireless switches (600088) and a home/away switch (600085).

4 Likes

Many thanks for your detailed instructions! Quick question, were your devices first paired with the Legrand hub and had any firmware updates or with this done with the devices default firmware?

Asking as I have a couple of wall switches and power sockets but not the hub so still on default firmware.

Sorry I didn’t see your message earlier, for some reason I didn’t receive any notification.

I never used the hub and I never willingly updated the firmware.

1 Like

Hello. Very interesting.
In the ZigBee device DB https://zigbee.blakadder.com/plugs.html the Celiane products are not reported as working with ZHA.

By any chance did you try to connect Legrand Celiane plugs ?https://www.leroymerlin.fr/v3/p/produits/prise-connectee-blanc-celiane-with-netatmo-legrand-e1501175778
Thanks

@drcoolzic I’m also interested to know if the plugs works with ZHA, did you try ? Thanks

Unfortunately I did not get answer and I did not try!
From what I iunderstand it seems like legrand s working on Channel 11

Thanks !
Trying on channel 11 but got nothing… Wonder what I’m missing. May not even be compatible

For those who want to know, I’ve finally succeded in pairing a Legrand wall plug.
First you need to switch to channel 11. Not just in zha config, you need to change your zigbee router’s configuration. In my case with the Conbee 2, I used the phoscon app (deconz has a bug and doesn’t retain the change).
Then it should pair with either ZHA or zigbee2mqtt (can’t use both fyi). I used the latter, but it should probably work with ZHA too.
Also note that the plug does not send electrical consumption if it has not been updated with its Hub… I didn’t since I don’t need it, but that’s quite unfair IMO.
Edit: I’m told domoticz can update firmwares without the hub. IDK about home assistant though.

1 Like

Thanks gor the feedback

Hi
I am using an Electrolama CC2652 stick. I can only switch the channel in ZHA. I don’t have a utility like the one I have for Conbee. How can I change the channel in the stick as well?

Hi, I’ve also switched to the Electrolama stick without problem. It seems enough to change the channel in zha for it.

It does not work with this pairing mode the Legrand 752191 (Valena Life Curtain switch):

  • You must have access to the reset button on the device
  • Make sure that the gateway is not in pairing mode
  • Press 8s (approximately) on the reset button of the device (until it turns red) to ensure its disconnected from the network
  • Now switch your gateway to pairing Mode
  • Press the reset button 8s (approximately) to start the pairing procedure
  • Make successive clicks on the reset button (every second), until the LED turns green

Hi,

Legrand recently released a new firmware (NLT-50) for its Wireless Switch On / Off switches (product type ZLE18, Ref No. 067773, for details see here https://developer.legrand.com/documentation/compatible-product/).

After resetting device, NTL-50 scans for ZigBee an open channel and binds to the open network. Here are the details: https://developer.legrand.com/forums/topic/how-to-change-zigbee-channel-for-ref-067773-2/. So, you don’t need anymore to stick to channel 11!

Moreover, all devices with recent firmware versions can by easily paired with third-party ZigBee coordinators. Procedure is described here: https://developer.legrand.com/documentation/how-it-works/. I tested it myself with both wired and wireless devices. It works like a charm, compared to the old firmware versions. In the past it was really not easy to pair.

The only problem, you need recent firmware. Legrand didn’t release them yet. Thus you still need Legrand hub to update your devices. Wired devices can be easily updated - just wait some time. But wireless devices doesn’t always want to update. Here is a procedure to force them to update:

  • If possible, best is to first remove and put back the battery
  • Push the switch button and wait 10 seconds
  • Redo it 10 times and wait 10 seconds between each push
  • Normally, in the next 30 minutes, the firmware should be up to date (version 42 or more)

It is described here: https://developer.legrand.com/forums/topic/wireless-switches-not-updating/

I hope that was useful.

2 Likes

Many thanks very useful information :slight_smile:

This is very encouraging.
If Legrand releases FW, how will it be possible wireless devices to upgrade without HUB?

1 Like

Hello there,

I am having a hard time with pairing this device. (This a legrand netatmo 752185, whixh has unmarked cover, and under that on the “middle cover” says off and on. Not sure is there difference between the pairing process or not, just to be as specific as possible)
My choice of zigbee stick is electrolama’s zzh (CC2652R) (because that is what I realy want).
So… I want to pair the HA. I learned that I need to change the radio channel. So reflashed my stick (just in case), and added than added these lines to my configuration.yaml, and re-added the integration:

zha:
  zigpy_config:
    network:
      channel: 11 # What channel the radio should try to use.
      channels: [11, 16, 21] # Channel mask

After that I pushed the pairing button for a long time (+10 sec), and also other various lenght and order.
But never showed up when I tried to add it via the cordinator. ( Searching for ZHA Zigbee devices…)

So what step am I missing?
I only have this switch, so I can’t install a new firmware. (Maybe if I take it back to the shop I could, if that is must)