Trouble setting up Envoy-S-Metered-EM

Thanks to his py script I managed to calculate the installer password. But which repository is suitable for the integration of Envoy in HA?

Let me guess…your Envoy is equiped with the D7.x software version. The default Enphase integration only works with the old D5.x software version.

You need HACS and a custom integration in order to get it working.

My advice: use the Posixx integration. See here:

I spoke to a representative for Enphase in Europe. It turns out this function has been disabled in the EU version of the hardware. That is what I was told anyway. I tried to install the Envoy (D7.x software indeed) with the Posixx version without success.

When you use the posixx automation you need to fill in your IP address of the Envoy and no pass. Then use the tickbox “use enlighten”.

There you must login with your Enlighten credentials.

Then it will work.

Thank you for your efforts to help!

What I get is the following error:

User input malformed: expected str for dictionary value @ data['serial']
(I entered no pass and user default “envoy”)

If I also fill in the envoy serial number the following error comes up:

Unexpected error

User needs to be the IP address of the envoy in your local network.

Still the same unexpected error unfortunately…

How come you know all these settings? I can’t find this info in the readme…

It just worked for me.

  1. Plug in IP address in IP address
  2. Username is your Enlighten App Username
  3. Password is your Enlighten App Username
  4. Serial Number on the inside of your Envoy box probably in the garage.
  5. Check the Enlighten box.

If the user is the ip and the password is left blank, what is the host? it seems to be the host that is generating the (User input malformed: expected str for dictionary value @ data[‘serial’]) error

See a post above you.

Host should be the ip address of your Envoy.
Username is your Enlighten app username.
Password is your Enlighten app password.
Check the checkbox to use Enlighten.

Read this thread to understand and get more info:

I must be doing something wrong.

I tried http, https, and just the IP, all with no joy.

I didn’t get it running either.

In the end I was directed to the repository of Brian Campbell…
After uninstalling the old one I managed to get it running with his solution:

You must use only IP for the host.
And I think the entry below the Password, that’s the SERIAL NUMBER, which you must fill in.
You can see the serial number from the Enlighten app.

It is getting closer using;

Username: [email protected]
Password: thisisntrealeither
S#: 12195411594
Use enlighten checked

I get unexpected error.
I have downloaded the integration restarted HA.
If I go to I get in

You need to read few posts above, because you keep repeating that. Hints: about the host.

Ok, interesting comment here, and I thought I was in a community forum. If you truly know what I am doing wrong, please share it with me in clear specific phasing. I keep repeating everything, I keep rephrasing this hoping for something as simple as “Don’t use HTTP. Use number only, :thinking:” The problem is, as I said, I have tried it all three ways

If you are trying to say something else, and I am too dense to grasp it, slow it down and type to me like I’m a three-year-old.


Perhaps something truly helpful, you know, something like your serial number seems to be missing digits; you might want to check menu/system/devices/IQ Gateway to confirm that you have written the serial number down correctly. :v:

Did you already install the version by Brian Campbell?

I believe it even autofills your Envoy Serial Number…

I never got it working with any other solution.
All of them are almost identical and there are many flavours.

I did; the only thing auto-filled was the username: envoy, which, to get it working, was replaced with enlighten username.
Unfortunately, the issue that kept me from getting it working was “operator malfunction” I had written down my serial number incorrectly.

The simple path to success for me was.

Host: IP (digits only, no protocol[HTTP])
Username: enlighten username (email address)
Password: enlighten password
Serial #: IQ Gateway Serial Number (Login to
enlighten menu/system/devices/IQ Gateway)
Use Enlighten: checked

And it worked


Good thing you got it working now! Enjoy!