Trouble with Chromecast Audio different firmware versions

It’s so strange that we seem to be the only two having trouble here. I’m really curious if anyone else on the preview Cast firmware 1.28.xx is having issues. I could try upgrading my working 1.27 Chromecast, but I don’t really want to lose my only working Chromecast Audio.

Wild guess, your nickname sounds french, is by any chance your Google Home set to french? Mine is. Maybe the combination of this specific firmware, in french, isn’t so common.

Nope. English in the USA.

Here goes my far-stretched theory.

Same issues here on HASS.IO version 0.57.2.

Chromecast Audio version : 1.27.96538
Chromecast Audio version : 1.28.100555
Chromecast TV version : 1.28.100555

All of them are somehow not visible anymore and i’ve got the idea since it from the latest Home Assistant update, but according to this topic it’s not Home Assistant but probably has to do with the update from Google.

Temporary I added the chromecasts on the following way, but in the past I had some issues with this

#  - platform: cast  

# Chromecast Slaapkamer 
  - platform: cast
# Chromecast Audio Woonkamer  
  - platform: cast 
# Chromecast Audio Tuin  
  - platform: cast 

I just had an issue of a segfault which occurred while an automation was running for my chromecast audio. This happened once before while I was on 0.55. I am currently on 0.57.2 (just upgraded today). I was curious to see if there was a known issue when I came across this. I do not have any problems with 0.57.2 recognizing my chromecast audio however after digging deeper I noticed I am also on version 1.28.100555 and did not recall ever signing up for this preview but upon checking within the Home app I found that it was set to receive the preview software. I have now unchecked it but it makes me wonder if this is the reason for my sudden segfaults when sending tts or an audio file to the chromecast audio.

Nov 08 16:30:00 raspberrypi hass[12389]: INFO:homeassistant.core:Bus:Handling <Event call_service[L]: service_call_id=1971404368-128, domain=media_player, service=volume_set, service_data=volume_level=0.3, entity_id=media_player.chromecastaudio1>
Nov 08 16:30:00 raspberrypi hass[12389]: INFO:pychromecast.controllers:Receiver:Launching app CC1AD845
Nov 08 16:30:00 raspberrypi hass[12389]: INFO:pychromecast.controllers:Receiver:setting volume to 0.3
Nov 08 16:30:00 raspberrypi systemd[1]: home-assistant.service: Main process exited, code=killed, status=11/SEGV
Nov 08 16:30:00 raspberrypi systemd[1]: home-assistant.service: Unit entered failed state.
Nov 08 16:30:00 raspberrypi systemd[1]: home-assistant.service: Failed with result ‘signal’.

I’m pretty convinced it has to do with the 1.28 updated cast firmware considering both @kernald and I tried various older HA versions in Docker containers. Please comment on the github thread if you haven’t already. I’d love to get this fixed soon so I can use my cast devices.

Does it work for you when you configure them this way?

It’s working but all the groups what are configured in the Google Home app you can’t see them.
So use some groups from my mediaplayer for automation and they don’t work anymore offcourse

I’m not sure we’re facing the same issue, then. Not speaking of groups, I can’t even see my Google Home at all on Home Assistant anymore.

Damnit my last working Chromecast Audio just randomly updated itself to, and now it doesn’t show up in HomeAssistant. This is so frustrating because is supposed to be a preview firmware that you sign up for, and I never signed up. So annoying!

I think I have a Chromecast still in its box somewhere. I’ll make some tests with it - configure it in hass, check if it appears (I don’t know if I will be able to set it up without updating though, but I’ll try), and wait for it to disappear.

Looks like we should get a fix in the next release:

Thanks everyone!

Everyone still having issues seeing as the merge was removed?

I still have the issue indeed.

Yes. With .59 my cast devices are discovered, but I can’t control them. With .59.2 they aren’t discovered.

Yes, still issues with 0.59.2. I configured them manually with:

  - platform: cast
    host: 192.168.x.x
  - ...

When hass boots I sometimes hear the chime, but sometimes not.
Playing media isn’t working at all…

I am having the same issues, rolling back to .58.1…

on rolling back to 0.58.1 my chromecast devices are still not being discovered… :frowning:

For me the issues started under 0.58.1 when the cast firmware was updated to 1.28.100555. I think rolling back to 0.58.1 will therefore not solve the problem due to the new cast firmware.