Troubles running on Proxmox


I’ve been runnin Home Assistant for about a month on VirtualBox and was very satisfied with how it went. I decided to move on to a more permanent solution and installed ProxMox on a spare desktop I had lying around. I followed the installation guide on this forum and succesfully went through all the steps. Home Assistant is running and the web UI is accessible, but none of the addons seam to work. Event the configuration file checking add-on stops after a short while. In the ProxMox console, I see a lot of these events:

It’s the “entered blocking state”, “entered forwarding state” and “entered disabled state” lines that worry me most. Is this normal? Is it a problem with Home Assistant or with ProxMox? What can I do to fix this?

How did you install HA Core? Using the OVA-image:
Or in another way?

No addons working normally means no supervisor installed.

Which addon is not working and how do you know ot is not working, is it not accessible? Do you have errors in the addon log?

i assume he runs a supervised version because in the logs it states hassio: multiple times in the logs he posted.

Thanks for replying. I installed and started “Check Home Assistant configuration”, “Mosquitto broker”, “Node-RED” and “Visual Studio Code”. The first one just stops and must be restarted. Node-RED and Visual Studio Code both give “Bad gateway” errors when trying to access the Web UI. The installation steps I was folliwing, are these:

And in “Check Home Assistant configuration” logs, indeed I see this:
s6-svscanctl: fatal: unable to control /var/run/s6/services: supervisor not listening

Ah, you’ve used Whiskerz script, it is known to give problems. I think I’ve seen a strong recommendation from Frenck not to use it anymore.

Let me see whether I can find back how to do it using the ova-image I’ve listed in my above message…

Update: if I remember correctly, I’ve used this solution:

Thanks for the pointers. Will try tonight! I’ll keep you posted.

Hooray! I think it’s working okay. Thanks for the help everyone!

Super! Glad to be able to help you out :slight_smile:

Can you select a Solution-post so anyone coming to this topic can see how you’ve solved your issue?

I might have been a bit to excited too soon. Everything does indeed look to be okay, but if I make changes to the configuration file, those aren’t picked up. If I add a formatting error to the yaml-file, the config checker add-on complains about that, so I’m sure I’m editing the correct file. None of the entities I configured show up. Even changing logging level to debug doesn’t result in extra entries in the logs. I found a similar post on this forum, but aparently, it had to do with multiple instances of docker containers. Just to be sure, I rebooted Home Assistant and ProxMox, but it didn’t help. Any tips on this issue?

Would be helpful to know which devices you tried to add through configuration.yaml. Do you see any errors in the home assistant log under Configuration -> General -> Logs?

There’s nothing there. I changed logging level to debug, so I guess I should at least see something? Devices I’m trying to add are KNX devices. I copied the configuration from my working Virtual Box environment. I think it has something to do with ethernet not being reliable in my proxmox environment. Are those state changes I mentioned in my opening post a reason for concern?

As a test; I added a sensor like this:

    - platform: systemmonitor
        - type: memory_free

This kind of sensor probably doesn’t need anything network related, so I guess there’s not much that could go wrong, but it doesn’t show up. It feels as if my whole configuration.yaml is ignored.

So far as I know that advice specifically refers to the script that makes an LXC container. The one that creates a VM will give you the same result as any other install on Proxmox.

I feel so silly now… the entities not showing up was because of wrong indentation in configuration.yaml. Visual Studio Code add-on probably added extra spaces when I was copy-pasting over my old configuration in there. So in conclusion, the Whiskerz script would probably have worked as I was having the same issues with the other method. It was all my own fault. Sorry for taking your time.

Kind regards

I just checked Whiskerz007 repo, indeed, as @DavidFW1960 writes, the script has been updated to use an official hassio image. I was using the old script, creating an LXC, and that one was having issues.

he has always had 2 scripts. One for a VM and one for LXC. It’s only the LXC one you really shouldn’t use.

I use proxmox lxc using Ubuntu 20.04 template, it ships with python 3.x and since I only run home-assistant in the container I find there is no need for using python virtual environments. So just follow the official guide and don’t make use of python venv.

One benefit, not sure, but I think you can simply upgrade python in the operating system without having to rebuild the python virtual environment for each upgrade.