Trying to recover 'bricked' device

Essentially. But hope isn’t really necessary as esphome set’s the “successful boot” flag not right after booting (typically only a few seconds) but has kind of a “cool down” till it declares a boot “successful”. So just power cycle it like 10 times every 10 seconds should easily let you activate the safe mode.

But one thing you can even try even before activiting the safe mode is to just try to ota it directly:

So in that case if you have esphome locally installed (for example with pip) on your laptop you should be able to call:

esphome run garden_lights_front_1.yaml --device

from the terminal to verify, compile and ota upload directly to

Thanks for all that, I’ll give it a try tonight.

Sorry to be a noob here but I get the following error:

C:\Users\David>esphome version
Version: 2022.9.0

C:\Users\David>esphome run garden_lights_front_1.yaml --device
←[32mINFO Reading configuration garden_lights_front_1.yaml...←[0m
←[31mERROR Error while reading config: Invalid YAML syntax:

Error reading file garden_lights_front_1.yaml: [Errno 2] No such file or directo
ry: 'garden_lights_front_1.yaml'←[0m


So I have no idea where I need to save the yaml file…

You can just open the terminal in the folder where the file is located and then just run the esphome ... command.

At the moment you are running esphome in that path: C:\Users\David

Ether copy your yaml to that directory (your “home” directory) or just open a terminal in the directory that stores your yaml file already :+1:

Thank you. I’m a step closer, I get the .bin file complied and ESPhome tries to connect to the device but it fails to connect. Perhaps I’m not power cycling it properly to get into the safe boot mode. I’ll keep trying with various on/off timing.


←[32mINFO Successfully compiled program.←[0m
←[32mINFO Connecting to←[0m
←[31mERROR Connecting to failed: [WinError 10061] No connect
ion could be made because the target machine actively refused it←[0m

Can you get logs from the device?

esphome logs garden_lights_front_1.yaml --device

Same error as above.

I’ll try a few more times to see if perhaps I’m not getting the device into safe boot mode.

And if that doesn’t work, it’s time for


Here is a link from OttoWinter the founder of ESPHome. This should help and answer some questions.

Interesting. Ok, so I was actually preventing safe mode by power cycling rather than just leaving it for a while.

Back to the test bench…

Thanks for the info Blacky

I tried opeing up this controller after many failed attempts to get access using teh ESPhome CLI but as I expected the device is completely filled with potting compound. It’s so frustrating because I feel like I was really close to getting somewhere.

Is the potting resin opaque or transparent ? If you can see the PCB through it, you may be able to reach the required pins or test pads by using a backlight, a column drill, a very fine drill bit and a loooot of patience… I have done that on one occasion. Once you’re done, you can refill the holes with epoxy resin.

Unfortunately the potting is black. I might see successful I am at chipping it out since I seem to have nothing to loose at this point.