TTS Setup to use with Google Home


Since a couple of months I’m using Home Assistant on a RPI4 and wow what can you do a lot with it :smile:
The last week I read a lot of articles regarding using TTS, I read the following article for setting-up ( Text-to-Speech (TTS) - Home Assistant ( but for some reason I don’t get any speech announcement from my Google Home, If I use a node red flow.
The function is executed but the only thing is no announcement is coming out!?
Sometimes I hear only a “Google sound” If I inject the flow but this doesn’t always happen!?
After searching the Internet I find a lot of articles saying that some Users report that this functionality doesn’t work anymore or at least something changed in the configuration!?
Some say you need a subscription to get it work!? So now I’m a bit confused or maybe it’s a misconfiguration from my side.

Maybe some of you have already been on this road and have found the solution or can point me to the right direction.

Kind regards

You do not need any kind of subscription for TTS.

Test the functionality using the Google Home media player cards within HA and skip node-red for now.


Check that your external and internal URLs are set correctly at the Configuration > General page in the UI. You need advanced mode enabled for your user in order to see those options.


I Tested the functionality as you suggested on the Google Home media card, after adding test in the Field Text to speak nothing happened after clicking on the Play Button.

The external url is pointing to my and the Internal url is point to the

In my opinion this should be correct…

Could it be that I also need to install Assistant Relay?

You probably need to change internal_url to be your address as well unless you’ve set up a reverse proxy.

If you get a warning from your browser about the certificate when you go to then do that.

No, you don’t need assistant relay. That’s for broadcasting and some limited commands…a different animal.

I changed the internal_url in my General Settings into so now the internal and external_urls are the same.

Next I restarted HA. but unfortunately the result is the same, no text spoken.

Another strange thing is if I send the Test message to the Device i hear sometimes a Google “chime” but if I try to send a message again no sound is coming out of the device!?

1 Like

That is expected.
When the media_player is idle then no chime will be played.
If you turn off between TTS commands then you will hear the chime every time.

On topic…
I gave up when I had issues with TTS last year and got the nabu casa subscription.

As @Hellis81 says, the chime is just the device waking up after receiving the command. It does the same if you were to hit the power button icon and send nothing or play nothing. After some period of time, the device goes idle again and the next time you use it, you would hear a chime.

What ports are you forwarding? Do you include :8123 in the url when you connect to your duckdns address in a browser?

@Hellis81 and @cogneato thank you for the information.

Regarding the Ports Forwarding I need to include the port :8123 after the Duckdns name.
Within my router I have forwarded port 443 to port 8123, that’s a bit strange that I have to use this Port number isn’t it!?

Normally I would have thought using port 8123 after the wouldn’t then be necessary.
I also checked with website if Port 8123 is open but this check leads to an unsuccesful result…

Could it be that I have something misconfigured in DNSMasq?
I have no external DNS servers Set-up in the configuration file of DNSMasq.

But then again I have to say that I have no problems of accessing HA Externally or Internally

Settings of my DNSMasq configuration:


    forwards: []
  • host:
    services: []

I found the solution by removing port 8123 from the Base URL in my configuration File the problem was solved.

Thanks to article:

SOLVED: No TTS output from Google Home - Home Assistant OS - Home Assistant Community (