TTS update

thanks :slight_smile:

Alexa doesn’t support notifications yet. Hopefully this will come soon!

Hope too! !

Are HASS and VLC on the same machine (IP) are you are serving trying to serve TTS to VLC on a another machine?

I forgot to mention that after changing the VLC volume, tts works flawesly!

How do you install VLC and how do you change the volume?

% sudo apt-get update % sudo apt-get install vlc browser-plugin-vlc

And I was using the ubuntu gui to change the volume

Thanks. I do this on Raspberry Pi 3.

sudo apt-get install vlc-nox

Do I need to change the volume?

I tried the nox version but it did not worked for me at all.

i see. in that case do i need to uninstall vlc-nox? why do i need to install browser-plugin-vlc? I am installing this on a headless server.

You should check beforehand on Google how to change VLC volume in cmd.
I didn’t had the time to mess around if I need the browser plugin or not so I just installed the whole package.

Hi @masterkenobi

I installed vlc-nox toi

It works fine…

how do you make it works? From my understanding, in order to make HA “speak” thru a speaker attached to the Raspberry Pi, I need to install VLC media player using sudo apt-get install vlc-nox and add this to the configuration.yaml

media_player:
  - platform: vlc
    name: VLC

tts:
  - platform: google

After that, I have to call the TTS service in my automation. For example…

- alias: 'Forecast Alert'
  trigger:
    platform: state
    entity_id: sensor.owm_forecast
  action:
    - service: tts.google_say
      entity_id: media_player.vlc
      data_template:
        message: "The weather forecast is now {{ trigger.to_state.state }}."

However, it was not working. Am I wrong somewhere?

I think you have the same problem that i had…
VLC works ? Can you test to play file on it in command line ?

Erm… how to do that? I can see there is an MP3 generated in the log. When I went directly to the URL (https://192.168.1.111:8123/api/tts_proxy/e66331a59a8c091a7723736291267e6741d21ac4_google.mp3) in my browser, it plays nicely.

So you need to go to terminal where your mp3 is
And execute vlc name.mp3

I only have the URL. Where do you think is the path to the mp3 file?

Anyway, I manage to play another MP3 file using the suggested command and it was successful.

the process hass runs with which username ?

the path of mp3 is configured in your config

`tts:

  • platform: google
    cache: true
    cache_dir: /tmp/tts
    time_memory: 300`