Tuya 2 and no more HACS

Suddenly my Tuya no longer works in HA . Tuya is fine on my cell phone app.
I have the newest HA Version 2021.10.4 so. . I have tried all morning and HACS will not show up in Add integration and Tuya2 will not show up in Add integration… I followed all the youtube videos on HACS and Tuya 2 , they install prefect… but after trying different browsers…clearing cache many times… nothing… no HACS… no Tuya 2

revert back to older homeassistant. only solution. wasted hours on this the other day. hours. the entire day.

1 Like

holy shit… you are correct… it works fine in Version
core-2021.9.6 WTF??

Apparently HACS also stopped working… I deleted all folder with HACS ,… reinstalled… Logger: homeassistant.loader
Source: custom_components/hacs/helpers/functions/download.py:9
Integration: hacs
First occurred: 3:29:43 PM (1 occurrences)
Last logged: 3:29:43 PM

Error loading custom_components.panel_custom. Make sure all dependencies are installed

My HACS is working, though. HAOS w/ Core 2021.10.4.

The Tuya fiasco came down to the fact that Tuya wants to discontinue the old API in the near future, and wants everyone to move to v2, starting core 2021.10.
Tuya’s intension here itself is (arguably) fine. The problem being the V2 codes that was submitted by Tuya are sub-par / rough / buggy / incomplete / whatever you want to call it, and that Tuya didn’t think it through while planning the migration.

Well. shoot… I have an old Pi3 at my warehouse… for shits ang giggles… I installed HACS and TUYA2 and both came up perfect first time AND this is with the newest latest code… no need to clear cache… just came right up 1st try . So … still no luck at all on my home Pi4 where I really need Hacs and Tuya2… It will not show up… ever!! Even after I reverted back to older code… I have no idea what to do here. I am really stuck because I can NEVER upgrade HA and soon TUYA will die… I have a lot of TUYA stuff.

Update… I am starting from scratch and so far so good… HACS went in first shot… easy peasy next Tuya 2 … YES~!~ Tuya 2 installed… Cannot log in … no way… i tried all afternoon…

yeesh… they dont make this easy

So the fix was to go back to the Tuya Lot site and create a brand new project, lik the phone app . I logged into Tuya 2 first time. Working great now in the latest newest code
Newest Version

Does Tuya2 work locally? (wifi in warehouse without internet access)

No. “Cloud Push” it reads.

No… for no internet access you have to use what is called LOCAL TUYA in HACS. You would need to learn how to extract and get all the local keys and IDs first