Tuya devices state not updating properly

I fixed it using the Smart Live App username and password on home assistant tuya integration setup, and not the user created for the associated project in tuya iot.

1 Like

As I had (what looked like) the same issue.
Loggin into my Tuya account seemed to have fixed all the problems for me…

thx for sharing!

Im having the same issue - tuya switches are not updating thier state in HA. Whats the best work around?

use tuya-local?

Thinking of trying that. I’m new to HA, is there a guide out there for local tuya setup? I noticed its not listed under the HA integrations.

It is available under HACS
see also GitHub - rospogrigio/localtuya: local handling for Tuya devices

thanks, does local Tuya give less issues than than ‘tuya’ ?

I only have one device, but so far it never had issues ever

Had the same problem but have finally solved it! In Tuya dev I revoked all service api except IoT Core and Authorization Token Management. After that everything works with correct state on my Tuya devices.


I tried the last solution provided by phobosman yesterday, but this morning I found the same issue, so it didn’t work for me.

However, I found that it is enough to restart the Tuya integration and it works again, so I do not need to restart HA.

Now, I have to understand if there is a way to set up an automatic restart of the integration or something similar.

i have the same problem i reload the integration then it start to work normally,
i found the devices not update the state and back to the previous state, i have 72 devise and now slowly i start use the app automation It is no longer reliable and I am frustrated with so many problems of this kind,
if you found some way to automate auto reload please let me know


I have also noticed the same strange behaviour with the Tuya integration over the last two weeks. Sometimes the status updates and other times it doesn’t.
A restart or integration reload fixes it for a while.

Same issue here over the last few weeks. Control works but no status updates.
Oddly, my devices are split between the place where HA is running and another location… it is only ever the devices in the “remote” location that stop syncing. All the ones in the house with HA continue have so far continued to work reliably.

As above, reload of tuya fetches correct status.

Update: Scratch that, seems to be all devices though hasn’t happened for a few days now.

Thanks a lot! This fixed it for me :slight_smile:
Screenshot 2023-04-11 at 13.57.56

Having the same issue for the last 2 weeks . I disabled ipv6 in HA and solved it for couple of days and now it’s been happening at least once a day . I don’t know why . I’m starting using scenes to turn on tuya appliances within HA as tuya scenes work fine within HA .
Bit annoying this tuya thing I don’t know why they haven’t properly integrated with HA . Only hassles that integration but I can’t do anything as I have lots of appliances working with tuya ( air purifiers , pet feeder , robot vac , dehumidifier, kitchen appliances etc ) .

Have 2 plugs installed and installed appropriate (HOPE SO) templates. Got the same issue. But here

  • the status is correct and updates immediately

  • the voltage is shown when plugged in (did not verify if numbers are correct)

whereas current and currentconsumption do not update, even after reloading or new start of HA. Just occasionly one of both will update after restart of HA and stay with what is indicated until switched off. then will stay with “0” even when switched on for minutes…
Does anyone have a working installation not showing this issue???

Thought I was going crazy. For me it’s limited to Zigbee lights on the Zigbee hub. I use automations to turn off a night-light and control the color temperature and brightness of lights in the bathroom. But all of the sudden these aren’t working anymore through home assistant.

I had to revoke all service api including IoT Core and Authorization token management. After adding them again and reloading the integration it worked.

Had the same problem. In Tuya dev I revoked all service api and readded them again. After reloading the integration now everything works !

1 Like